Outbound Dial Issues

configuration
Tags: #<Tag:0x00007ff2e9017488>

(Daniel) #1

Hi,

i’m new to freepbx. Sofar everything worked just fine for me. But there is one issue i cant solve.
Dailing a Nation number works just fine. But as soon i try to call to an international number Freepbx tells me “all circuits are busy now”.
So Dailing 0621 123 123 works just fine. But 0048 123 123 for e.g. will result in “all circutis…”

On my Trunk Number i had set this Dail Number Manipulations Rules:
(0) 0 | [ZZZZ.]

On Outbound Routes i had set:
( ) | [.]

This Information i got from a german Youtube video.

I hope someone have an idea whats wrong :confused: or how to debug this more futher.

PS: Here a Full Log with asterisk debug on enabled: https://pastebin.freepbx.org/view/a8db1932

Best Regards Daniel


(Lorne Gaetz) #2

Lines 171-3:

[2021-10-05 11:33:06] VERBOSE[17854][C-000000c1] app_dial.c: Called PJSIP/[email protected]_062199999    
[2021-10-05 11:33:06] VERBOSE[17854][C-000000c1] app_dial.c: PJSIP/telefon01_062199999-000002f6 is making progress passing it to PJSIP/12-000002f5     
[2021-10-05 11:33:06] VERBOSE[17854][C-000000c1] app_dial.c: Everyone is busy/congested at this time (1:0/0/1)

with two identical attempts that follow. Call attempt was made and rejected by the provider, I expect they can tell you why it failed if the cause is not obvious.


(Daniel) #3

Totaly right. My Provider has disabled calling international. now it is working fine!

Thank you!


(Jared Busch) #4

You have you pattern matching backwards, yes it can work, but better (best) practice is to normalize the outbound number in the outbound route. Then you apply any trunk specific things in the manipulation for the trunk.

Aside from that you are removing and leading a zero in you manipulation prefix and then prepending it. That is useless

In your outbound route for in country calls you want no prepend and no prefix and a match of 0X.

Now, you need to decide how you want your users to dial international calls. Then you make a pattern match in the route for that.

In your trunk you have no pattern matching at all.


(system) closed #5

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.