Outbound CNAM displayed on Caller Phone?

I’m trying to determine if the following behavior is expected and if there is a way to change it.

I have a whole bunch of Yealink T22P phones. When I place an outgoing call from any of these phones, at first it displays the number dialed on the screen. Once the called party answers the call it displays "CID:< MyOutbound# >. The call history also lists these calls as "CID:< MyOutbound# >. This is very annoying. Every placed call looks the same. You have to click on the call details to see what the number was.

Now, I’ve done some testing and it seems that this is being caused by setting “sendrpid = Send P-Asserted-Identity header”. If I change it to “sendrpid = no” then it will display the dialed digits. But then internal calls (extension to extension) won’t display names. And I believe I read that this also effects how transfers are displayed.

HERE is a thread on the Yealink forums about someone else experiencing this exact same issue.
http://forum.yealink.com/forum/showthread.php?tid=873

The Yealink Support Admin says this;

Because your server send the 200 OK with a display name in P-Asserted-Identity: "CID:0575250438 . In the PAI-FROM, phone will get the display name from your PAI、RPID.(CPSource=0). So you can see the display name CID:0575250438 in the history. If you want to change the display name, please change the header of P-Asserted-Identity.

Basically I’m trying to determine why the PIA header is showing CID< MyOutbound# >, how to change it to at the very least be the dialed digits or better yet to a CNAM lookup, and finally retain PIA so I can preserve the benefits it provides with extension to extension dialing.

I saw mention in another thread to perhaps set Advanced Settings -> Dialplan and Operational -> Display CallerID on Calling Phone to False. I haven’t tested this yet, but plan on it tomorrow.

Thanks.

1 Like

Hard to get feedback around here it seems…However, I think doing;

Advanced Settings -> Dialplan and Operational -> Set Display CallerID on Calling Phone to False

is a suitable resolution for me. It allows me to keep PIA on for extension to extension calls and outbound calls now display the dialed digits (after manipulation by dial plan) in placed/outbound calls. This is much better.

Ultimately it would be nice to be able to do a CNAM lookup but from what I’ve read this isn’t a standard/easy thing to do.

Yes that is the setting you want to set. By default if your extension is setup for sendrpid since the CID Name is not used on outbound calls on your phone we use that to show what Caller ID was used for your call as a feature and as you see you can turn that off.

Not sure why you would want to as showing the Caller ID does not hurt anything. The Yealinks in Call History should show both Name and Number field not just the Name field. This would be a shortcoming on the phone then.