Outbound CID Problem

We are running FreePBX, and recently decided to connect some resilience SIP trunks via a second provider. This new provider is causing a bit of a headache, as they require a trunk ID in the from field and the extension CID in ether the PAID or RPID headers.

I have tried various configurations but the only one that works is to have Force Trunk CID set but this overrides the Extension CID and places the Trunk CID in both the PAID and RPID headers meaning that I can not pass individual CIDs for extensions.

Does anyone know how I can configure outgoing calls to send the Trunk CID in the From header and the extension CID in the PAID and/or RPID header?

PJSIP trunk advanced tab -

1 Like

Thank you for the suggestion, but I am already doing this. Here are the Settings I am using are as follows

CID Options : Force Trunk CID
Trust RPID/PAI : Yes
Send RPID/PAI : Both
Send Private Caller ID Information : Yes

The issue is how to allow a different CID in the PAID / RPID Headers to that in the From header.
The Force Trunk CID places the Trunk number in the From Header but also overwrites the PAID & RPID headers with the Trunk CID. Any other Trunk Option allows the extension CID to be passed in the PAID & RPID headers but also overwites the From header which is mo use.

Apologies billsimon, I missed the From User field on the graphic. It is, after all, only the biggest thing on the screen.

Putting the Trunk CID in the From User and changing the Trunk Option to Block Foreign CIDs did the trick.

Thanks for the help.

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.