Outbound CID ignored [SOLVED]


#1

Hey guys,

when I call an external number via sip-trunk I want to transmit my external-no and not my internal extension-no.
Therefor I set “outbound cid” in my user-settings to my external number.
Unfortunately the internal extension-no is used.

To be honest I’m a bit shocked that this is even possible… I call an external no. and they are receiving a call from “13” ??? How is this even possible…?

Sip-Log:

<— History Entry 14974 Sent to 88.79.204.9:5060 at 1563195076 —>
INVITE sip:EXTERNALNO@88.79.204.9:5060 SIP/2.0
Via: SIP/2.0/UDP 92.79.124.70:5060;rport;branch=z9hG4bKPje3085dd5-4af6-484b-9050-62b0a31680f8
From: “MYNAME” sip:13@MYDOMAIN.ngn.vodafone.de;tag=da7e7a0e-a180-44db-a46a-2b29ebecc284
To: sip:EXTERNALNO@88.79.204.9
Contact: sip:asterisk@MYIP:5060
Call-ID: f790530c-fe42-411e-88f8-f2ac5d7a87d1
CSeq: 8187 INVITE
Route: sip:88.79.204.9:5060;lr
Allow: OPTIONS, SUBSCRIBE, NOTIFY, PUBLISH, INVITE, ACK, BYE, CANCEL, UPDATE, PRACK, REGISTER, MESSAGE, REFER
Supported: 100rel, timer, replaces, norefersub
Session-Expires: 1800
Min-SE: 90
P-Asserted-Identity: “MYNAME” sip:13@MYDOMAIN.ngn.vodafone.de
Remote-Party-ID: “MYNAME” sip:13@MYDOMAIN.ngn.vodafone.de;privacy=off;screen=no
Privacy: none
P-Preferred-Identity: sip:MYEXTERNALNO@MYIP;user=phone
Max-Forwards: 70
User-Agent: FPBX-14.0.13.4(15.4.0)
Content-Type: application/sdp
Content-Length: 306

v=0
o=- 697628934 697628934 IN IP4 92.79.124.70
s=Asterisk
c=IN IP4 MYIP
t=0 0
m=audio 45612 RTP/AVP 9 8 0 3 101
a=rtpmap:9 G722/8000
a=rtpmap:8 PCMA/8000
a=rtpmap:0 PCMU/8000
a=rtpmap:3 GSM/8000
a=rtpmap:101 telephone-event/8000
a=fmtp:101 0-16
a=ptime:20
a=maxptime:150
a=sendrecv


(Lorne Gaetz) #2

You probably have a misconfiguration somewhere, a call trace should identify where:
https://wiki.freepbx.org/display/SUP/Providing+Great+Debug#ProvidingGreatDebug-AsteriskLogs-PartII


(Dave Burgess) #3

I see this all the time when I set the outbound trunk to “Intracompany Route”. I’ll bet you have that turned on.

You can also override the extension’s number in the outbound by setting the outbound trunk to the Caller ID you want to use and set it to “ignore extensions settings”.


#4

Hi,
that was exactly the problem. THX!


(system) closed #5

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.