Outbound Calls "All Circuits Busy"

I’m very much a newbie… But I’ll try to give as much detail as possible.

Inbound calls are working just fine…

Outbound, as the title states says “All circuits are busy”.

The trunk is showing as offline… It was showing this way yesterday also, I thought maybe an update would fix it… but no…

Also… this happened a few weeks ago, then suddenly it seemed ok.

Yesterday, I was running some updates, and it did fail… Thanks to this board, I was able to fix the issue… it was related to userman ? I didn’t take note… but I remember running a manual download/install from the CLI and then everything seemed OK except for the trunk…

Today I tried to figure out why calls are not going out… I’ve been able to figure that the pbx is not connecting the trunk provider (telnyx)… seems like nothing is coming out of the box at all…

I ran asterisk -r and the following came up

Connected to Asterisk 11.23.1 currently running on localhost (pid = 2137)
[2017-07-06 02:25:34] SECURITY[2138]: res_security_log.c:134 security_event_cb: SecurityEvent=“ChallengeSent”,EventTV=“1499307934-212990”,Severity=“Informational”,Service=“SIP”,EventVersion=“1”,AccountID="sip:[email protected];transport=UDP",SessionID=“0xb762967c”,LocalAddress=“IPV4/UDP/192.168.0.67/5060”,RemoteAddress=“IPV4/UDP/192.168.0.17/34882”,Challenge=“4b946c58”
[2017-07-06 02:25:34] SECURITY[2138]: res_security_log.c:134 security_event_cb: SecurityEvent=“SuccessfulAuth”,EventTV=“1499307934-226892”,Severity=“Informational”,Service=“SIP”,EventVersion=“1”,AccountID=“14165555555”,SessionID=“0xb762967c”,LocalAddress=“IPV4/UDP/192.168.0.67/5060”,RemoteAddress=“IPV4/UDP/192.168.0.17/34882”,UsingPassword=“1”
[2017-07-06 02:25:34] WARNING[16208][C-00000e35]: app_dial.c:2455 dial_exec_full: Unable to create channel of type ‘SIP’ (cause 20 - Subscriber absent)
[2017-07-06 02:25:36] SECURITY[2138]: res_security_log.c:134 security_event_cb: SecurityEvent=“ChallengeSent”,EventTV=“1499307936-65701”,Severity=“Informational”,Service=“SIP”,EventVersion=“1”,AccountID=“201”,SessionID=“0xb54ca83c”,LocalAddress=“IPV4/UDP/192.168.0.67/5060”,RemoteAddress=“IPV4/UDP/192.168.0.14/5060”,Challenge=“0e59ab1a”
[2017-07-06 02:25:38] WARNING[16208][C-00000e35]: channel.c:4861 ast_prod: Prodding channel ‘SIP/2380-000001ec’ failed
[2017-07-06 02:25:39] SECURITY[2138]: res_security_log.c:134 security_event_cb: SecurityEvent=“ChallengeSent”,EventTV=“1499307939-849924”,Severity=“Informational”,Service=“SIP”,EventVersion=“1”,AccountID=“201”,SessionID=“0xb54ca83c”,LocalAddress=“IPV4/UDP/192.168.0.67/5060”,RemoteAddress=“IPV4/UDP/192.168.0.14/5060”,Challenge=“47e69cb5”
[2017-07-06 02:25:40] SECURITY[2138]: res_security_log.c:134 security_event_cb: SecurityEvent=“ChallengeSent”,EventTV=“1499307940-365371”,Severity=“Informational”,Service=“SIP”,EventVersion=“1”,AccountID=“201”,SessionID=“0xb54ca83c”,LocalAddress=“IPV4/UDP/192.168.0.67/5060”,RemoteAddress=“IPV4/UDP/192.168.0.14/5060”,Challenge=“47e69cb5”
[2017-07-06 02:25:41] SECURITY[2138]: res_security_log.c:134 security_event_cb: SecurityEvent=“ChallengeSent”,EventTV=“1499307941-385636”,Severity=“Informational”,Service=“SIP”,EventVersion=“1”,AccountID=“201”,SessionID=“0xb54ca83c”,LocalAddress=“IPV4/UDP/192.168.0.67/5060”,RemoteAddress=“IPV4/UDP/192.168.0.14/5060”,Challenge=“47e69cb5”
[2017-07-06 02:25:42] SECURITY[2138]: res_security_log.c:134 security_event_cb: SecurityEvent=“ChallengeSent”,EventTV=“1499307942-585734”,Severity=“Informational”,Service=“SIP”,EventVersion=“1”,AccountID="sip:[email protected];transport=UDP",SessionID=“0xb762967c”,LocalAddress=“IPV4/UDP/192.168.0.67/5060”,RemoteAddress=“IPV4/UDP/192.168.0.17/34882”,Challenge=“6616fcb0”
[2017-07-06 02:25:42] SECURITY[2138]: res_security_log.c:134 security_event_cb: SecurityEvent=“SuccessfulAuth”,EventTV=“1499307942-616537”,Severity=“Informational”,Service=“SIP”,EventVersion=“1”,AccountID=“14165266134”,SessionID=“0xb762967c”,LocalAddress=“IPV4/UDP/192.168.0.67/5060”,RemoteAddress=“IPV4/UDP/192.168.0.17/34882”,UsingPassword=“1”
[2017-07-06 02:25:42] WARNING[16217][C-00000e36]: app_dial.c:2455 dial_exec_full: Unable to create channel of type ‘SIP’ (cause 20 - Subscriber absent)
[2017-07-06 02:25:43] SECURITY[2138]: res_security_log.c:134 security_event_cb: SecurityEvent=“ChallengeSent”,EventTV=“1499307943-465280”,Severity=“Informational”,Service=“SIP”,EventVersion=“1”,AccountID=“201”,SessionID=“0xb54ca83c”,LocalAddress=“IPV4/UDP/192.168.0.67/5060”,RemoteAddress=“IPV4/UDP/192.168.0.14/5060”,Challenge=“47e69cb5”
[2017-07-06 02:25:44] SECURITY[2138]: res_security_log.c:134 security_event_cb: SecurityEvent=“SuccessfulAuth”,EventTV=“1499307944-285840”,Severity=“Informational”,Service=“AMI”,EventVersion=“1”,AccountID=“admin”,SessionID=“0xb7278dbc”,LocalAddress=“IPV4/TCP/0.0.0.0/5038”,RemoteAddress=“IPV4/TCP/127.0.0.1/41182”,UsingPassword=“0”,SessionTV=“1499307944-285835”
[2017-07-06 02:25:47] SECURITY[2138]: res_security_log.c:134 security_event_cb: SecurityEvent=“ChallengeSent”,EventTV=“1499307947-564994”,Severity=“Informational”,Service=“SIP”,EventVersion=“1”,AccountID=“201”,SessionID=“0xb54ca83c”,LocalAddress=“IPV4/UDP/192.168.0.67/5060”,RemoteAddress=“IPV4/UDP/192.168.0.14/5060”,Challenge=“47e69cb5”

So I guess the question is… Any ideas on what steps I can take? Next steps?

From shell:
asterisk -rvvvvvvvvv
sip set debug on
< place call out >
exit

Copy all scrollback from the first command until ‘exit’ to pastebin.com. Save the link, paste the resulting pastebin link here.

Thanks so much for your help…

https://pastebin.com/vxgezBAY

@intravista What carrier is this? They’re not replying to OPTIONS, yet you’re trying to qualify. Set qualify=no in the trunk peer config and retest.

Edit:
Sorry, just saw; there’s extensive documentation on getting this working with telnyx; are you using user/pass or IP auth?

Yes, it is telnyx… And I followed their setup to a tee. The same setup worked really well on another freepbx server.

Using IP auth.

Tried with qualify=no … Went from “All circuits are busy now” to dead air.

@intravista Yeah, that’s expected. You’re likely sending the invite repeatedly with no response. Join us on IRC and we’ll troubleshoot this live. I’m out of patience for this format :slight_smile: #freepbx on Freenode. Online support option in the Admin menu, or there’s a web client free at https://webchat.freenode.net.