Outbound Calling SIP Trunk

siptrunk
Tags: #<Tag:0x00007f702400b6a8>

(Handy) #1

Hi members, I just took over a customers site that had a FreePBX and I am switching to a new SIP provider. I have access to the GUI and command line too. however, I have not used FreePBX in a while.

I am having issue with outbound calling.

  1. I suspect that SIP ALG may be active on the end customers network or the FPBX is an edge device as it seems to be doing some routing on its own. I have checked the customers’ network and I can’t see SIP ALG turned on.

  2. I note that outbound calls from the FPBX are sending the ‘From’ field as 0298323411 at 111.111.222.123 when we would expect to see 0298323411 at mysip dot com

Where do you set or change the from outbound to send the domain of the registrant opposed to the public IP.

Many thanks in advance.


#2

The domain name sent in the From header can be set in From Domain for a pjsip trunk or with
fromdomain=provider.com
for a chan_sip trunk.

However, though it is common for trunking providers to require their domain name in the From header, I have never heard of one that requires the registrant’s (customer’s) domain name.

If you have used this provider before, you could compare the trunk settings with those on a working system. If not, does the provider have documentation of required settings?

If you still have trouble, please post some details: Provider? Router/firewall make/model? Error status returned for attempted INVITE?