Outbound calling issue

siptrunk
Tags: #<Tag:0x00007f7029477b60>

(Droop) #1

NEWBY to freepbx. We’re moving to a new server and new version of freepbx. I inherited this system . We have same provider. I used the SIP settings from the existing server. Provider issue new UN/Passphrase for new SIP trunk. We have a test number on it. I can get inbound calls, outbound calls get recording all trunks are busy or busy signal.

Dashboard shows trunks offline.

I’ve verified settings with provider.

Any suggestions appreciated.


(David Johnson) #2

I had a similar issue. Make sure your extensions caller ID is set and in the correct format “text”

There were some major changes recently due to “megans law” in the US. If the caller ID is not set in freepbx I can NOT make any outbound calls but inbound works fine. In my environment the phones are also external so I also have to make sure the NAT is set yo Yes for chan_sip phones (haven’t been able to get pjsip to work anymore)

What trunks are you using? I am using telnyx and I have found that trunks with username/password authenticatino was very unreliable and I had to switch to IP based authentication.


#3

If your PBX language is English, the message resulting from the provider rejecting the call is “All circuits are busy now.” Any other announcement was likely played by the provider or his upstream.

If you are using registration and receiving calls, it was obviously successful and an offline indication is likely caused by qualify (OPTIONS packets) not getting a timely response.

The Asterisk log should show what is happening. If on an outbound call, "Called " (without the quotes) appears in the log, it was sent to the provider and rejected. At the Asterisk command prompt, type
pjsip set logger on
or
sip set debug on
as appropriate for your trunk type. The provider’s response should indicate why it was rejected and you can inspect the INVITE for incorrect formats, etc. You can do the same on the working server for comparison.