Outbound callerid shows anonymous

FreePBX: 10.13.66-11

CallerID set in Trunks
Setting them in outbound routes and/or extensions makes no difference

Currently using <##########>
Wanted “Co Name” <##########>

SIP provider says trunks have callerID set.
I’m stumped.

Likely we are all also stumped, do you want to flesh out your question to include logs and what exactly your problem is?

I’d be happy to do that but I will need some direction.

It’s all in the wiki that is linked at the top of this page.

Ah, go read the book. It would be nice if the answer for my issue was in there.
The issue is in the subject.

If you don’t have the time or patience to RTFM (bad idea), or your ability to search the wiki for how to provided useful debugging logs, then your issue is likely with your provider not honoring your requst for callerid(num) as mentioned in the wiki.

Good luck otherwise though

Seriously, telling me to read the book is not being helpful. Clearly, it’s not intuitive because the logs talked about things I’m not using. It’s not a good design.

So, I went back to the console. I ran a report because I had the customer call today so I could test the callerID as I made changes. The report is call event logging.

2017-02-21 08:44:30 00:00:00 Unknown <0000000000> called CID:1234567890 <1234567890>
2017-02-21 08:45:17 00:00:00 Unknown <0000000000> hung up

it shows unknown in the log. When they called, it shows anonymous, at least as a name, I’m not sure if the number was included. I checked my phone but this area had a power outage and my call/receive log on my phone isn’t there.

The report show called, answered, I hung up, they hung up. I listed the first and last which shows their name being unknown or anonymous on my end.

Does that help? Is it possible the SIP provider has made an error?
I had requested they use “Co Name” <##########>
Customer said anonymous was intermittent.
They have two trunks, so is it possible one trunk has the right info and one doesn’t?
Also, when I removed the name and just went with the number, could that be an issue because the SIP provider needs something from the PBX?

If you wont do as asked, at least read /var/log/asterisk/full

Two things:

  1. We’re usually a pretty forgiving and friendly crowd, until we aren’t. If we have answers here, we’re under no obligation to provide them to you if we don’t want to. Most of us don’t work for Sangoma.

  2. The fact that the problem is intermittent is a clue that it may be outside of your control. If you go through the /var/log/asterisk/full logs and find where the caller ID is set and where the call is placed, you might find a disconnect.

At this point, the only information we have is that you are proudly too lazy to search through a relatively short document on how to set up Caller ID or to even Google this problem yourself.

There are too many places where caller ID can fail. You’ve not given us any indications on which ones you’ve eliminated, or that you’ve actually done more than call someone whose system may actually be the problem.

So, spit on one of us again, or start trying to help us troubleshoot. Your move.


And honestly right now it sounds like it might not even be a FreePBX/Asterisk problem…

When I read this

I wondered where?

On their website? In LIDB/CNAM?

Are updates to LIDB/CNAM propagated rapidly or does it take a while and might explain the occasional anonymous?

The SIP provider cannot say it is always set unless it is set on something under their control or something they can submit updates to…

And this further suggests this:

If so, this is not even a FreePBX/Asterisk problem…

Have a nice day!


1 Like


That’s what i needed. Just a little direction. Thank you.

Not sure if my problem is resolved but I can provide what I saw and what I changed. This may help others who “don’t have the time or patience to RTFM” because as Dave concluded, “proudly too lazy to search through a relatively short document on how to set up Caller ID or to even Google this problem.”


I have been working on this, not just this day, but today since 8am. It’s almost 10pm here. I might not be “that” lazy. It is not something I work in a lot, I’ve had no direction and I’m willing to accept the errors are my own.

And, Dave, I have searched the net. I found lots of documents that provided no help in troubleshooting this. Google doesn’t like to give recent returns unless you force the time frame. So, most articles are not much help.

The main Wiki page: http://wiki.freepbx.org/#all-updates has a search box. It would have been helpful to know, DO NOT SEARCH FROM HERE. Click on FreePBX OpenSource Project first. You can search from here but there is a link Asterisk Log Files which you and dicko posted.

cd /var/log/asterisk
nano full

I scrolled to the first test at 8:44am
Again I saw, Unknown.
I also saw TRUNKCIDOVERRIDE and it had only the number.

So, I setup a remote extension, since I’m remote to the customer and nobody is there.
I called and saw Anonymous
So, I am getting the number but it says Anonymous for the name.

In nano to go to the end of the file
I saw Unknown again for name.

So, I set caller ID for both trunks as “Co Name” and tested.
Everything worked as it should.

I don’t know why it’s working now because it was set that way originally.
My guess is it’s time to call the SIP provider back because maybe Trunk 2 [which is the trunk my test happens to choose] is the only one with the CID set, which would explain the intermittent issues they were having, which Nick mentioned.

Apparently, and perhaps someone else knows, the SIP provider was expecting something the CID to be set as “Co Name” and when I removed the name, it showed anonymous but still gave the number. I don’t know if the SIP provider can set it to accept what the PBX provides, but looks that way.


This is SipStation’s (Sangoma’s VoIP service) documentation but still might provide some insight as to how this is supposed to work:


I am not in the US though so I can’t confirm whether it really works that way in the US or not (and I am not even sure if you are in the US or not…).

Does this apply in your case, I can’t say and you seem to have control over what you are sending from FreePBX…

Here (Canada) I can pass whatever I want (at least with the providers I tried this with)…

Good luck and have a nice day!


Generally in the lower 48 few if any carriers will honor your callerid(name) the big carriers “dip” into the LERG database, a few VSP’s will at a cost so register your number with that name there, (LERG is VERY expensive and generally only covers land lines in NANP land ( including you Canucks) :slight_smile: cellphone carriers down here have yet to agree on anything :wink: ) in the far north Roger’s et all will happily accept callerid(name)

1 Like