Outbound Caller ID not working always shows up as Private or Unknown

No matter what I put in for outbound caller id it always shows up as private or unknown. We are using SIPSTATION trunks with the SIPSTATION module. Running FreePBX version 2.9. I have contacted them and they say it is because I am not populating the outbound CID field in the extensions but I am. it just does not work. I have also tried the trunk CID option too. Still no go. anyone have any ideas? Maybe a firewall issue???

note: SIPATATION says they are getting “unknown” in the CID field from the PBX.

You have a valid DID in the CID field of the extension?

Is this a distro install or built by hand. What version of Asterisk?

Yes it is a valid DID number. It is actually the main number. And it is the 2.9 version of FreePBX distro.

@trixwatts Hey, did you eventually solve this? I have the same problem.

Kind regards & thx

I submitted a bug report for this problem as I am having it as well. It can be seen at www.freepbx.org/trac/ticket/5773