Outbound Caller ID not send

Hi guys,

Iam using the newest FreePBX Distro with no commercial modules.
Everything is updated to the newest version.

Our VoIP Provider is SIPGATE in Germany
I configured everything (almost) correct. I can make calls internal and external. I can receive calls on different numbers.
But when i call somebody he sees the fallback number ending in 49.
For every extension i set the outbound caller id like this:
“Lukas” <4930577043290>

and in the /etc/asterisk/extension_custom.conf i wrote this

exten => _X.,1,Set(CALLERID(number)=1577268t3)

exten => _X.,n,SipAddHeader(P-Preferred-Identity:sip:[email protected])
;exten => _X.,n,SipAddHeader(P-Preferred-Identity: <sip:${CALLERID(name):!}@sipconnect.sipg$
exten => _X.,n,Dial(SIP/${EXTEN}@sipgate,30,trg)
exten => _X.,n,Hangup

Sipgate told me that iam not sending my cid. Maybe i didnt configure an important point. I don’t know what to write more to discribe this problem. Please ask. Thats much easier for me. Iam very new to FreePBX and tried EVERYTHING on google.

Thank you and sorry for my english

P.S:sipgate requires p-preferred-identity

I have to bump this. It’s very important that i can solve this problem.

I know nothing about sipgate, but the following may be useful:

Use SIP debug (or tcpdump) to confirm that your added header is being sent as you expect.

Check the format required. Perhaps you need to send 030577043290, or maybe +4930577043290.

If no luck, do you have access to a working example (IP phone or softphone registered directly to sipgate, or another PBX system that is sending the correct caller ID)? If so, compare the outgoing INVITEs to see what’s different about your system.

I looked at the sipgate site. My German is not too good, so I may have found the wrong page, but these rates seem outrageously high: http://www.sipgate.de/trunking/tarife . If so, consider Voxbeam or AnveoDirect. Both allow you to put the caller ID in the From header with no issues. Both provide a small credit at signup, so you can test without making a payment.

Sample rates (best quality routes):
Germany fixed: Voxbeam $0.0088, AnveoDirect $0.0068, sipgate €0.01
Germany T-Mobile: Voxbeam $0.0329, AnveoDirect $0.0269, sipgate €0.129???


thank you for your answer.
I now enabled sip debug. according to which pattern I have to keep eye out? (google translator on this sentence, :S).
Sip gate requires e.164 format which i thought was <4930577043290>.
We use Sipgate team with a flatrate. http://www.sipgate.de/team/produkte
For comparison i have an innovaphone ip810. I don’t know if i can watch the INVITEs send but i will have a look.

Thank you

Check that in the relevant outgoing INVITE (the one with an Authorization header) has your added P-Preferred-Identity header, properly formatted, and does not have any conflicting (P-Asserted-Identity or Remote-Party-ID) headers.

To compare with Innovaphone (which I know nothing about), see if the phone has an option to log SIP packets to syslog (use Wireshark if you don’t have a syslog server).

If not, capture the raw traffic from the phone:

If you have a managed switch, you can use the “port mirroring” or “port monitor” feature. Or, temporarily set up a dumb (10 Mbps) hub (not switch) connecting the phone, your PC and the LAN.

Or, use a PC with two NICs, set up with the connections bridged or with Internet Connection Sharing. For example, PC connects to network by Wi-Fi, connection shared to Ethernet port, IP phone plugged into Ethernet port (may need crossover cable). Then, run Wireshark on PC to capture traffic from the NIC to which the phone is connected.

The last post by dawas in http://www.freepbx.org/forum/general-help/ppreferedidentity will likely solve your issue.

I posted the soulution in the following post:



Hi Dawas and Stewart.
Thank you!
One Question, do I have to restart to apply those configs ?

Thank you Dawas. You saved my week!

hello can you send me your settings. the link is unfortunately no longer possible.

Thank you very much