Outbound call on trunk sets CONNECTEDLINE name to outbound CID


This is basically the problem described in this thread but it never got a proper solution.

There is a line in macro-dialout-trunk that sets the CONNECTEDLINE name to outbound CID configured on the trunk:

exten => s,n,ExecIf($[$["${DB(AMPUSER/${AMPUSER}/cidname)}" != ""] & $["${CALLERID(name)}"!="hidden"]]?Set(CONNECTEDLINE(name,i)=CID:${CALLERID(number)}))

which then gets sent as rpid/pai to an extension making an outbound call.

I have no idea what the purpose is, it messes up call history in Sangoma Talk mobile app and on our Grandstream phones because all outgoing calls are displayed as CID:<our_outbound_CID>.

I don’t want to disable rpid on all extensions, I only want to prevent FreePBX from sending these wrong, in my opinion, headers to extensions making outbound calls.

I know I could override macro-dialout-trunk and fix it myself, but I will do it as a last resort.

Is there a simpler way to disable this behavior?

Solved it.

Settings → Advanced Settings → Display CallerID on Calling Phone-> Set to “No”

This disables CONNECTEDLINE CNAM but only on outbound trunk calls.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.