Outbound call drops after 30 seconds

My FreePBX dropped it’s calls after 30 seconds, both inbound as outbound. I was able to fix the inbound calls by setting the correct local networks in SIP settings => NAT settings, but I’m struggling with the outbound calls. I have checked another FreePBX and applied the same settings, but without result.

NAT is set to “Yes”.

Am I looking in the right place?

This question pops up a lot on the forum, and usually is has something to do with router/NAT/firewall settings. I did a quick forum search and came up with these:

There are a lot (a lot) more if you haven’t had the chance to review them.

I have found all of them and non of them seem to be related to my issue. Should I:

  • Set RTP Timeout to a higher number?
  • Set “Reinvite Behavior” to “yes” and (in my trunk setting) canreinvite=no => canreinvite=yes?
  • Set NAT to “no”, to be honest: I don’t know what this does … NAT on the router is enabled?

I have set “RTP Timeout” and “RTP Hold Timeout” to 3600, now the calls seem to last longer than 30 seconds. I guess the RTP Timeout (which was set to 30) caused this issue. Hoping the outbound calls won’t be longer than 1 hour, this solved the problem I was having. If someone has a more durable solution, I’m open for suggestions. I have also mailed my provider for suggestions on this topic.

Apparently my solution did not work, so it’s back to the drawing board.

If the audio is working (for the first 30 seconds), then the problem is unrelated to RTP.

Determine from the log whether the extension or the trunk is being dropped, and why. If it’s not clear, post a link to a paste of the log, including a SIP trace (mask credentials and other personal details as desired).

This is the log from around a call:


check ALG from your router and codecs as well.

Following an old post, I decided to reboot the server. You know what, it solved the issue. Think I’m going crazy.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.