Outbaound Caller-ID for SIP trunks

May I did wrong but in my cases, when I configure SIP trunks between FreePBX servers or Elastix or others, Caller id of calls is equal with ‘fromuser’ or ‘dialed number’ (rpid), and outbound Caller id in trunk or Route CID in outbound route are ignored.

It’s my system issue again?

Explain again what the problem is.

there is an issue in caller-id field for trunk and outbound route. calls don’t use this caller id field.

http://www.asteriskdocs.org/en/2nd_Edition/asterisk-book-html-chunk/I_sect14_tt599.html

look for how and if you need to use and set “fromuser”

thanks dear I read it. But my question is that when I’m using ‘fromuser’, caller-id filed will be ignored, yes?

Did you read the .
.
The fromuser parameter is going to affect the way our INVITE message is structured when sending the call to the provider. By setting our username in the fromuser parameter, we will modify the From: and Contact: fields of the INVITE when sending a call to the provider. This may be required by the provider if it’s using these fields as part of its authentication routine. You can see the places Asterisk modifies the header in the next two code blocks.
.
.
bit in the link?

Did you try the options while watching your sip debug ?

How did it turn out?

yes dear I read. but when peer authenticate you with username and not IP, you don’t have any chance for sending caller-id !!! what about RPID?

You would need to talk with your provider.

1 Like

servers are local. just 2 FreePBX!!

Then you need to talk to yourself :wink: setting up “tie-line trunks” between two FreePBI is covered in the wiki linked at the top of this page.

I found this trouble too when my SIP trunk with Twilio needed “fromuser” set. The answer was to put “sendrpid=pai” in the Trunk Peer Details. I encountered it again when I set up a new PJSIP Trunk. For this type there are switches in the advanced settings for the trunk. I needed to set “Trust RPID/PAI” to “Yes” and also set “Send RPID/PAI” to “Send P-Asserted-Identity header”. I was then able to pass the caller ID from the extension’s setting. CID set at Trunk or Outbound Route will also pass through.
I’ll add that I’m not sure why I didn’t need “trustrpid=yes” in the Peer Details for the standard SIP trunk, but did need to set that switch in the PJSIP trunk.

… this thread is 5 years old… and I believe twilio’s setup docs explicitly tell you how to set up freepbx.

Sholinaty - Oh their documents do tell you how to set up with FreePBX, however they give you the most basic functionality and leave out key details. Half of what I needed to do to get it working right was not in their documentation or their outdated youtube videos. Their support team responded to tickets mostly by pointing me to their documents, and by telling me they could not offer help with PBX configuring. I had to google my way through forums like this to resolve all of the issues.

fair. when i set up Twilio on a freepbx install last month, it worked flawlessly by following Only the guide.

It will work fine if you only have 1 DID with them and don’t need to pass CID from the extensions.

ive got it on 30+ DIDs (after confirming I own the numbers).

I’ve never had to pass extension CID, as I prefer to use dialing prefixes and outbound routes for that purpose :slight_smile:

glad you sorted it out though

1 Like

This thread was about calls direct between two FreePBX systems.

It has nothing to do with any provider setup.

1 Like

I was migrating from an older version of FreePBX, and the company owner had been using it this way for years with Voip.ms. After all the downtime last month with the DDOS attacks he wanted to switch to Twilio, and to a new PBX. Carrying over all his config settings was a bit challenging. Seems to be working ok now.
One example of an undocumented necessity is putting the list of their signaling and media IP’s in the “Match (Permit)” setting of a PJSIP trunk. Before doing that I found some inbound calls not making it through. Ugh. Unfortunately they wouldn’t tell me how to set that either. Thankfully the support at the server hosting site was more helpful.

1 Like

sorvani - I thought it was about CID settings being ignored when fromuser= is set.