Our phones voicemail answers, and does not accept menu options being pressed, also cannot call out


(Codejoy) #1

I inherited a freepbx system at this site I work at. I have no idea how it works and am not really familiar with PBX in general. It has been a pretty easy to maintain system as it has not given many fits and generally you use the UI to add new phones and users etc. Not to bad.

Though last night at about 2am users noticed calls could no longer be made from phone to phone or off site, and calling the site it goes instantly to voice mail options (which it was supposed to only do during site closed hours). The going to voice mail options asks users to press a button to ring certain parts of the site, though the system ignores these button presses. I was looking at logs from the machine itself in /var/log/asterisk/full

and saw that sometime the normal logging of reports like:

[2021-05-30 03:31:56] NOTICE[7296] res_pjsip_exten_state.c: Extension state subscription failed: Extension 307 does not exist in context ‘from-internal’ or has no associated hint
[2021-05-30 03:31:56] NOTICE[21900] res_pjsip_exten_state.c: Extension state subscription failed: Extension 99213168 does not exist in context ‘from-internal’ or has no associated hint
[2021-05-30 03:31:56] NOTICE[2471] res_pjsip_exten_state.c: Extension state subscription failed: Extension 9924
168 does not exist in context ‘from-internal’ or has no associated hint
[2021-05-30 03:32:01] VERBOSE[32155] res_pjsip_registrar.c: Added contact ‘sip:102@10.75.5.20:5060’ to AOR ‘102’ with expiration of 900 seconds
[2021-05-30 03:32:01] VERBOSE[10792] res_pjsip/pjsip_configuration.c: Contact 102/sip:102@10.75.5.20:5060 has been created
[2021-05-30 03:32:01] VERBOSE[10792] res_pjsip/pjsip_configuration.c: Contact 102/sip:102@10.75.5.3:5060 has been deleted
[2021-05-30 03:32:01] VERBOSE[6299] res_pjsip/pjsip_configuration.c: Contact 102/sip:102@10.75.5.20:5060 is now Reachable. RTT: 62.482 msec
[2021-05-30 03:32:01] NOTICE[14560] res_pjsip_exten_state.c: Extension state subscription failed: Extension 307 does not exist in context ‘from-internal’ or has no associated hint
[2021-05-30 03:32:01] NOTICE[13485] res_pjsip_exten_state.c: Extension state subscription failed: Extension 99213*102 does not exist in context ‘from-internal’ or has no associated hint

These kinds of lines above are in most of the /var/log/asterisk/full*

But sometime last night the full log started to show:

[2021-05-31 03:17:12] ERROR[2471] res_pjsip/pjsip_options.c: Unable to create request to qualify contact sip:144@10.75.5.56:5060
[2021-05-31 03:17:12] ERROR[32155] res_pjsip.c: Unable to retrieve PJSIP transport ‘asterisk’
[2021-05-31 03:17:12] ERROR[32155] res_pjsip.c: Unable to retrieve PJSIP transport selector for endpoint 162
[2021-05-31 03:17:12] ERROR[32155] res_pjsip/pjsip_options.c: Unable to create request to qualify contact sip:162@10.75.5.7:5060
[2021-05-31 03:17:13] NOTICE[14890] chan_sip.c: – Registration for ‘gVtDJet7ZghJ@trunk2.freepbx.com’ timed out, trying again (Attempt #587)
[2021-05-31 03:17:13] NOTICE[14890] chan_sip.c: – Registration for ‘gVtDJet7ZghJ@trunk1.freepbx.com’ timed out, trying again (Attempt #587)
[2021-05-31 03:17:14] WARNING[14890] chan_sip.c: Remote host can’t match request REGISTER to call ‘74f3c0850671784360f3b33a1904675b@[::1]’. Giving up.
[2021-05-31 03:17:14] WARNING[14890] chan_sip.c: Remote host can’t match request REGISTER to call ‘762a54e810916972749388ba74c4d116@[::1]’. Giving up.
[2021-05-31 03:17:14] ERROR[4272] res_pjsip.c: Unable to retrieve PJSIP transport ‘asterisk’
[2021-05-31 03:17:15] ERROR[26816] res_pjsip.c: Unable to retrieve PJSIP transport ‘asterisk’
[2021-05-31 03:17:15] ERROR[26816] res_pjsip.c: Unable to retrieve PJSIP transport selector for endpoint 163

I have verified our sipstation account is paid up, though the screen in freepbx UI under community->sipstation shows a red error that ‘the server is currently not responding, it is either unavailable for or access is being blocked. If server is unavailable please try again later’

Not sure which server, looked at sagomas uptime and nothing seems to be down. Not sure how to test or what server it is trying. I pinged trunk1 DOT freepbx DOT org and trunk2, it worked.

I see nothing else wrong, and not sure what to check next or do. Or how to even test. It is odd I can call site and the voice mail does answer, though pushing buttons and extensions does nothing and no one can call offsite. No changes were made to the server which has an uptime of 3 years +.

Do I want to just do a sudo shutdown -r now ? Anyway I can test from the ui to get an error report of why calls cannot go out and why our site doesn’t ring and goes right to voicemail (of which the menu options are meaningless) Any other logs to look in ? (not sure what I am even looking for)


#2

That’s fine, but I would first try
sudo fwconsole restart
and see what errors, if any, are shown on the console.
If no luck, try
sudo fwconsole chown
and then another
sudo fwconsole restart
If that doesn’t help, do the reboot.
If that doesn’t help, either, paste the Asterisk log starting from the reboot through a failing internal call attempt at pastebin.freepbx.org and post the link here. If you are too new to post links, post the eight hexadecimal characters at the end of the link. Also, please post the contents of /etc/asterisk/pjsip.transports.conf .


(Codejoy) #3

Great let me try these things now. I will put the pjsip transports conf file…though with the caveat that literally we had changed nothing (Since I don’t know the system I don’t really touch it)… but I will post.

#include pjsip.transports_custom.conf

[0.0.0.0-udp]
type=transport
protocol=udp
bind=0.0.0.0:5060
external_media_address=*..11.71
external_signaling_address=
..*11.71
allow_reload=yes
local_net=10.75.0.0/16


(Codejoy) #4

Results of sudo fwconsole restart
[root@pbx asterisk]# sudo fwconsole restart
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_COLLATE to default locale: No such file or directory
Running FreePBX shutdown…

Stopping RestApps Server
Stopped RestApps Server
Stopping UCP Node Server
Stopped UCP Node Server
Stopping Chat Server
Stopped Chat Server
Zulu Server is not running
Shutting down Asterisk Gracefully. Will forcefully kill after 30 seconds.
Press C to Cancel
Press N to shut down NOW
[============================] 30 secs
Killing asterisk forcefully.
Asterisk is still running and we can’t stop it!


(Codejoy) #5

I can now call on site, and they can call offsite, but phones on site phone to phone still doesn’t work it seems. The results of that chown and then second fwconsole restart is below: I still haven’t done the full reboot, guessing asterisk/freepbx or what not should start automatically? Not sure if the messages below are helpful but at least that chown and fwconsole restart did get some of the way there.

[root@pbx asterisk]# sudo fwconsole chown
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_COLLATE to default locale: No such file or directory
Taking too long? Customize the chown command, See
Setting Permissions…
Setting base permissions…Done
Setting specific permissions…
30192 [============================]
Finished setting permissions
[root@pbx asterisk]# sudo fwconsole restart
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_COLLATE to default locale: No such file or directory
Asterisk not currently running
Running FreePBX shutdown…

RestApps Server is not running
UCP Node Server is not running
Chat Server is not running
Zulu Server is not running

Stopping Wanrouter for Sangoma Cards
Wanrouter Stopped
Stopping DAHDi for Digium Cards
DAHDi Stopped
Queue Callback Server is not running
Running FreePBX startup…
Running Asterisk pre from Dahdiconfig module
Writing out default Sangoma conf
Starting Wanrouter for Sangoma Cards
Wanrouter Started
DAHDi: Already started
Running Asterisk pre from Firewall module
Running Asterisk pre from Pms module
Running Asterisk pre from Sysadmin module
Running Sysadmin Hooks
Restarting fail2ban
fail2ban Restarted
Updating License Information for 81370602
Checking Vpn server
Starting Asterisk…
[------>---------------------] 1 sec
Broadcast message from root at whatever com (Mon May 31 22:11:45 2021):

Firewall service now starting.

[============================] 2 secs
Asterisk Started
Running Asterisk post from Dahdiconfig module
Running Asterisk post from Endpoint module
Running Asterisk post from Pagingpro module
Running Asterisk post from Restapps module
Starting RestApps Server…
[>---------------------------] < 1 sec
Started RestApps Server. PID is 8655
Running Asterisk post from Ucpnode module
Starting UCP Node Server…
[>---------------------------] < 1 sec
Started UCP Node Server. PID is 8732
Running Asterisk post from Vqplus module
RestApps is not licensed.
Running Asterisk post from Xmpp module
Starting Chat Server…
[>---------------------------] 1 sec
Started Chat Server. PID is 8844
Running Asterisk post from Zulu module
This product is not licensed


(Codejoy) #6

Actually it took several hours but the phone to phone on site calling via extensions started to work too. So it seems that restart/chown/restart worked.