OSS Endpoint Manager no longer loads packages after upgrade to 13.0.2

It may be best to state something like this in the forum:

directory tree/filename

line number: code -
line number: code +

line number: code -
line number: code +


Or place the patch file on github.

I’m not even going to attempt to use patch via a copy/paste. Asking for trouble.

If you’d like to create the patch in notepad or the like and email it to me I’d be happy to place on github. My email is [email protected] or [email protected].

Scratching my head as to why something this simple one of the principles of the project wouldn’t just take 10 minutes, fix it and check it in. Guess this project has lost leadership or interest. The last contact I was sent has yet to reply.

It’s community supported and the most recent version works for me. What’s to fix?

Either of you could also go apply your fixes to github but you are instead asking to exchange fixes over private email. Seems counter intuitive

Whats to fix? Note the video in the first post on this thread 8 days ago.

Glad it works for you. The most recent versions don’t work for me and others who’ve updated and I doubt they work for any new comers due to broken code being checked in. It seems @beppoit has a fix, you mind providing intuitive direction on how he can apply it to the latest release? Does your Endpointman.class.php file contain what he’s provided?

Already released mid-afternoon.

The thing is there is no “principle” of OSS Endpoint Manager. That’s what I’m trying to convey and really it’s not a simple 10 minute fix. You have to first spend the time looking through the code base (it’s completely changed with the newest release) then figure out what’s going on. Much longer than 10 minutes.

updated to latest Beta release. Still unable to load packages.

Movie: enter link description here

I think I’ve made some progress investigating this. I’ve reverted the back to the latest stable version. Then attempted to configure the advanced confiraction variables. When clicking update variables, nothing changes. The values revert back to e.g. ftpboot/ when I’m attempting to change to a web dir using http.

The apache error logs show very little. These values reside in the database and are not being set for some reason by the gui.

I’m curious. Uninstalls from day one have not gone smooth for the module as I’ve had to remove the provisioning sym link to continue in most cases. I’ve then manually blown away all its directories and content. However, I’ve never cleared the endpointman tables or dropped them. If I were to go with the cleanest reinstall possible. What tables are safe to drop regarding endpointman before attempting a new install?

| endpoint_ext_buttons | | endpoint_ignoreMac | | endpointman_brand_list | | endpointman_custom_configs | | endpointman_global_vars | | endpointman_line_list | | endpointman_mac_list | | endpointman_model_list | | endpointman_oui_list | | endpointman_product_list | | endpointman_template_list |

The only errors I’m seeing the apache logs are as follows:

[Fri Feb 19 21:16:33 2016] [error] [client] File does not exist: /var/www/html/admin/assets/css/mainstyle.css, referer: https://pbx.totusagency.com/admin/config.p hp?display=epm_devices [Fri Feb 19 21:25:52 2016] [error] [client] File does not exist: /var/www/html/admin/assets/css/mainstyle.css, referer: https://pbx.totusagency.com/admin/config.p hp?display=epm_templates [Fri Feb 19 21:43:40 2016] [error] [client] File does not exist: /var/www/html/admin/assets/css/mainstyle.css, referer: https://pbx.totusagency.com/admin/config.p hp?display=epm_devices [Fri Feb 19 21:44:25 2016] [error] [client] File does not exist: /var/www/html/admin/assets/css/mainstyle.css, referer: https://pbx.totusagency.com/admin/config.p hp?display=epm_templates [Fri Feb 19 21:47:12 2016] [error] [client] PHP Fatal error: Class 'endpointmanager' not found in /var/www/html/admin/modules/endpointman/uninstall.php on line 1 3, referer: https://pbx.totusagency.com/admin/config.php?display=modules [Fri Feb 19 22:02:43 2016] [error] [client] File does not exist: /var/www/html/admin/assets/css/mainstyle.css, referer: https://pbx.totusagency.com/admin/config.p hp?display=epm_devices

update: I don’t think anything is wrong regarding the endpointman tables. All are empty except for globals which the gui doesn’t update.

`mysql> select * from endpointman_brand_list;
Empty set (0.00 sec)

mysql> select * from endpointman_custom_configs;
Empty set (0.00 sec)

mysql> select * from endpointman_line_list;
Empty set (0.00 sec)

mysql> select * from endpointman_mac_list;
Empty set (0.00 sec)

mysql> select * from endpointman_model_list;
Empty set (0.00 sec)

mysql> select * from endpointman_oui_list;
Empty set (0.00 sec)

mysql> select * from endpointman_product_list;
Empty set (0.00 sec)

mysql> select * from endpointman_template_list;
Empty set (0.00 sec)

Seeing the same here on a fresh 13 distro install and an upgraded from 12

wont load packages and wont hold onto settings and in teh beta no option to save either.

Good luck @cyberco its been 7 days since feedback. Been in this boat for 15 days now. As @tm1000 stated there is no principle on the module and no developers seem to be addressing this issue. All seems to be working fine for others, why us I still have not a clue. Thought maybe it may have something to do with httpd.conf configure, so I’ve been playing around with that as well, no remedy yet though.

There are two people working on trying to fix it. Please don’t be so quick to make assumptions. One of the people is in this thread.

Awesome! Had no idea as its been quiet here. Thanks for the update Andrew, great news!

Did have a look at Git repository and and stuff seems to be happening, but beta is more broken than stable at the moment. loathed to update from teh current git if thats as broke as beta.

Im guessing no one is using it as i pulled down a fresh distro iso loaded it on a vm . removed comercial endpoint and installed oss and its the same as yours and the other one im working on ;-(

Ok so has been released to “stable” smae issue still there, No save option in advanced and wont load packages manually or via the package manager. this has been tested on 3 systems and all the same.

If its being tested and working before stable can it be confirmed what packages are required. as in teh Freepbx distro there is something obviously missing.

We dont even see any activity or errors in teh httpd logs.


the oss endpoint manager was (a possibly still is) and interesting product but when Andrew joined schmooze some years ago we switched to the paid endpoint manager. the paid version is not without bugs but it does provide an easier mechanism for updating the basefiles and it does support a wider variety of phones. Yes you do have to pay for it, but given the amount of time i suspect some of you have invested so far and getting the oss epm to work, i think you will find the paid emp pretty cheap.

There is no save option because everything saves when you change it. Just confirmed this is working.

Can’t confirm this. Working fine here.

Every time the developer (not me) submits the work I check it on the freepbx distro.

Ok well having now tested it on 4 servers including a new distro install, all have the same symptoms. and these are echoed by other users,

I would recommend building a clean install, then you have to remove the paid version as it conflicts then install oss version and see if it works

I did it with a clean install. It worked.

Edit: Holy smokes, it was all just a browser issue. Using Firefox now and no issues.

I’m having serious problem like @cyberco, although mine seem a bit worse.

Updated to, and now can’t even view extensions. Receiving error
Can't Load Local Endpoint Manager Directory!
Tried uninstalling and removing OSS Endpoint completely, and can then view extensions.
Reinstalled, same problem comes back (and now don’t have lost my configuration, but can rebuild that I guess).

Tried importing packages and extensions csv manually, but new version cannot upload these files or set any other settings in fact as has been mentioned previously in this thread, so doesn’t seem working for me.

Now on beta version, but same results as above.

Next up I’ve tried a new install like @tm1000 suggested, but same problems. I installed OSS EPM first, and checked (same issue). Then upgraded other modules and still the same problem.

One other thing that may be of note, when trying to uninstall it on my production instance, I receive the following (although does appear to be uninstalled).
Error(s) removing endpointman: Failed to run un-installation scripts

Is there a way of perhaps installing the old version manually from before this started happening?

Ok fresh install on vmware here are my observations as it still didnt work

Please wait while module actions are performed
Upgrading endpointman to from track stable <<<< INTERSTING AS IT WAS INSTALL NOT UPGRADE
Downloading endpointman 692216 of 692216 (100%)

Installing endpointman
Error(s) installing endpointman:
• Failed to install OSS PBX End Point Manager due to the following conflicting module(s): EndPoint Manager
Updating Hooks…Done


Errors with selection:
• EndPoint Manager cannot be disabled because the following modules depend on it:
• Please disable those modules first then try again.
No actions to perform
Please select at least one action to perform by clicking on the module, and selecting an action on the “Action” tab.

package manager does not load

in advanced get
date_default_timezone_set(): Timezone ID ‘UTC/UTC’ is invalid

This is fixed by setting valid setting in Freepbx advanced settings
But with error fixed setting are not saved.
advanced brings up freepbxlog error

[2016-Mar-08 21:50:51] [WARNING] (libraries/modulefunctions.legacy.php:7) - Depreciated Function module_getinfo detected in /var/www/html/admin/modules/cxpanel/functions.inc.php on line 61

and package manager
[2016-Mar-08 21:50:51] [WARNING] (libraries/modulefunctions.legacy.php:7) - Depreciated Function module_getinfo detected in /var/www/html/admin/modules/cxpanel/functions.inc.php on line 52
[2016-Mar-08 21:50:51] [WARNING] (libraries/modulefunctions.legacy.php:7) - Depreciated Function module_getinfo detected in /var/www/html/admin/modules/cxpanel/functions.inc.php on line 61

when going to add an SIP extension "Can’t Load Local Endpoint Manager Directory!"
is displayed !

Also when trying to add a user in user manager
it throws an exception referencing appointment reminder…

<?php @Zend; 0611; ?>


Appointment Reminder 13.0.5
Copyright 2016 by Schmoozecom, Inc., All rights reserved

By installing, copying, downloading, distributing, inspecting or using
the materials provided herewith, you agree to all of the terms of use as

bear in mind this was a clean install …

im happy to assist but can you confirm what you did … to get yours to work as it seems odd no one else can get it to work.

Raphael just read your edit, downloaded firefox to my mac and yes your right works in firefox, but not safari or chrome.

So there we have it. not been tested fully. Im guessing it will be some of teh latest security updates in chrome.

But still getting other errors described, user manager error is fixed by disabling appointment reminder module

This message is generic and will show up for many things regardless of if you are “upgrading” or “installing”

No because the module’s rawname is “restapps”

These aren’t errors.

You force installed Appointment Reminders on a system that is not the distro. Therefore you have a compiled module on a system that doesnt understand how to read compiled modules.

I run off Chrome. Works fine in: Version 49.0.2623.75 beta (64-bit). The module is unsupported. Who is suppose to test this?

This is something I will get the developer to address

Overall this sounds like asset caching problems. Can any of you show me the javascript errors you are getting in Chrome and safari