OSS Endpoint Manager Exception building config files

Hi everyone, I have searched far and wide and I could not find any information. I have OSS Endpoing Manager installed v13.0.6.7, which is the latest up to now. After I upgrades this and other modules, which I don’t know which they were, as of two days ago, I cannot generate/build the config files anymore. I get and exception. I tried rolling back as far as version 2.11.13 but I get that error every time.

I am trying to provision several devices and I don’t quite know how to do this manually on remote devices.

FreePBX 13.0.119
PBX Firmware: 10.13.66-11
PBX Service Pack:

Thank you for any help.

Here is what I get on the page

Whoops\Exception\ErrorException thrown with message "copy(): The first argument to copy() function cannot be a directory"

#6 Whoops\Exception\ErrorException in /var/www/html/admin/modules/endpointman/includes/functions.inc:1280
#5 Whoops\Run:handleError in <#unknown>:0
#4 copy in /var/www/html/admin/modules/endpointman/includes/functions.inc:1280
#3 endpointmanager:write_configs in /var/www/html/admin/modules/endpointman/includes/functions.inc:1594
#2 endpointmanager:prepare_configs in /var/www/html/admin/modules/endpointman/includes/devices_manager.inc:154
#1 include in /var/www/html/admin/modules/endpointman/page.epm_devices.php:12
#0 include in /var/www/html/admin/config.php:563

Getting the same issue. Its also affecting saving any extensions that have devices configured. The only way to make changes to the extension is to delete the device (which throws the same error but does actually delete it). Adding the device from the extension module or the OSS EPM module both give similar errors. Reinstalling the OSS EPM does not fix it.

OSS PBX End Point Manager
32 bit FreePBX 13.0.124
PBX Firmware: 10.13.66-12

Here is the error when using the OSS EPM (same as yours)

and here is what happens when editing an extension

  1. Whoops\Exception\ErrorException

  2. Whoops\Run handleError

  3. copy

  4. endpointmanager write_configs

  5. endpointmanager prepare_configs

  6. endpointman_configpageinit

  7. FreePBX\GuiHooks doConfigPageInits

I’ll probably just go buy the paid EPM to fix this. works perfectly for me. Later versions are horribly broken though.