Options missing "join/leave ,Record conference, Talker optimization"

using freepbx 2.11

actually i want to record my conference. and also wanted to use join/leave option.

however as per my finding three options are missing from “application>conference>[my conference number]”

even in “application>call recording” is set my meeting room to “record immediately,Allow and etc.” i tried all option but call recording didn’t work.

is there anyone can help me in this regard.

Thanks,

Myk

here is the log

– Executing [[email protected]:1] Gosub(“SIP/503-0000002e”, “recconf,1(conf,500,500)”) in new stack
[2013-07-24 12:50:12] ERROR[16031]: pbx.c:3892 ast_func_read: Function MEETME_INFO not registered
[2013-07-24 12:50:12] WARNING[16031]: func_logic.c:192 acf_if: Syntax IF(?[][:]) (expr must be non-null, and either or must be non-null)
[2013-07-24 12:50:12] WARNING[16031]: func_logic.c:193 acf_if: In this case, =’’, =’’, and =‘conf-500-500-20130724-125012-1374652212.52’
– Executing [[email protected]:1] Set(“SIP/503-0000002e”, “__CALLFILENAME=”) in new stack
[2013-07-24 12:50:12] ERROR[16031]: pbx.c:3892 ast_func_read: Function MEETME_INFO not registered
[2013-07-24 12:50:12] WARNING[16031]: ast_expr2.fl:468 ast_yyerror: ast_yyerror(): syntax error: syntax error, unexpected $end, expecting ‘-’ or ‘!’ or ‘(’ or ‘’; Input:
!
^
[2013-07-24 12:50:12] WARNING[16031]: ast_expr2.fl:472 ast_yyerror: If you have questions, please refer to https://wiki.asterisk.org/wiki/display/AST/Channel+Variables
– Executing [[email protected]:2] ExecIf(“SIP/503-0000002e”, “0?Set(DB(RECCONF/500)=)”) in new stack
– Executing [[email protected]:3] Set(“SIP/503-0000002e”, “MEETME_RECORDINGFILE=/var/spool/asterisk/monitor/2013/07/24/”) in new stack
– Executing [[email protected]:4] Set(“SIP/503-0000002e”, “MEETME_RECORDINGFORMAT=wav”) in new stack
– Executing [[email protected]:5] ExecIf(“SIP/503-0000002e”, “1?Return()”) in new stack
– Executing [[email protected]:2] Return(“SIP/503-0000002e”, “”) in new stack
– Executing [[email protected]:6] GotoIf(“SIP/503-0000002e”, “0?READPIN”) in new stack
– Executing [[email protected]:7] Answer(“SIP/503-0000002e”, “”) in new stack
– Executing [[email protected]:8] Wait(“SIP/503-0000002e”, “1”) in new stack

any help will be highly appreciated i have been stuck in this for quite few days i can not find anything on internet related to the errors showed up in log.
please help.
i also tried app_meetme but it auto revert back to app_confbridge where console shows that app_meetme is not installed.

i am very confused. would anyone please helpme.

You are using FreePBX 2.11 but you didn’t say what kind of system was it installed on and what OS.

thanks for your response, it is Debian 6.0.7, using KVM virtual machine.

1 GB memory and xeon Processor 3.0. actually machine is hosted on a Good server node. memory and processing power and internet is not a problem. RAM can be increased. but i think 1GB RAM for just testing is enough.

sorry i forgot to add, i am using asterisk 1.8

Then the next question is how did you install Asterisk and FreePBX? DO NOT USE apt-get the deb’s they are very broken.

apt-get update && apt-get upgrade -y

#libcurl4-gnutls-dev is for CNAM in Asterisk
#sudo is needed later on, even while root
#ntp to keep time updated otherwise it goes to year 2032 after shutdown
apt-get -y install build-essential linux-headers-uname -r openssh-server apache2 mysql-server mysql-client bison flex php5 php5-curl php5-cli php5-mysql php-pear php-db php5-gd curl sox libncurses5-dev libssl-dev libmysqlclient-dev mpg123 libxml2-dev libnewt-dev sqlite3 libsqlite3-dev pkg-config automake libtool autoconf git subversion sudo libcurl4-gnutls-dev ntp

pear install db

reboot

cd /usr/src
wget http://downloads.asterisk.org/pub/telephony/asterisk/asterisk-1.8-current.tar.gz
tar xvfz asterisk-1.8-current.tar.gz
cd asterisk-1.8*
./configure
contrib/scripts/get_mp3_source.sh
make menuselect

make
make install
make config

cd /var/lib/asterisk/sounds
wget http://downloads.asterisk.org/pub/telephony/sounds/asterisk-extra-sounds-en-gsm-current.tar.gz
tar xvfz asterisk-extra-sounds-en-gsm-current.tar.gz
rm asterisk-extra-sounds-en-gsm-current.tar.gz

The latest revision was 15499 when I installed mine, which is what I installed and am using

export VER_FREEPBX=2.11
cd /usr/src
svn co http://www.freepbx.org/v2/svn/freepbx/branches/${VER_FREEPBX} freepbx
cd freepbx

adduser asterisk --disabled-password --no-create-home --gecos "Asterisk User"
chown asterisk. /var/run/asterisk
chown -R asterisk. /etc/asterisk
chown -R asterisk. /var/{lib,log,spool}/asterisk
chown -R asterisk. /usr/lib/asterisk
mkdir /var/www/html
chown -R asterisk. /var/www/

sed -i ‘s/(^upload_max_filesize = )./\120M/’ /etc/php5/apache2/php.ini
cp /etc/apache2/apache2.conf /etc/apache2/apache2.conf_orig
sed -i 's/^(User|Group).
/\1 asterisk/’ /etc/apache2/apache2.conf
service apache2 restart

export ASTERISK_DB_PW=amp109
mysqladmin -u root create asterisk
mysqladmin -u root create asteriskcdrdb
mysql -u root asterisk < SQL/newinstall.sql
mysql -u root asteriskcdrdb < SQL/cdr_mysql_table.sql

mysql -u root -e "GRANT ALL PRIVILEGES ON asterisk.* TO [email protected] IDENTIFIED BY ‘${ASTERISK_DB_PW}’;"
mysql -u root -e "GRANT ALL PRIVILEGES ON asteriskcdrdb.* TO [email protected] IDENTIFIED BY ‘${ASTERISK_DB_PW}’;"
mysql -u root -e “flush privileges;”

./start_asterisk start

./install_amp --webroot /var/www/freepbx

#I installed these FreePBX modules, you might not want these or may want others
amportal a ma upgrade core
amportal a ma upgrade framework
amportal a ma upgrade recordings
amportal a ma upgrade announcement
amportal a ma upgrade asteriskinfo
amportal a ma upgrade backup
amportal a ma upgrade callwaiting
amportal a ma upgrade cidlookup
amportal a ma upgrade conferences
amportal a ma upgrade dashboard
amportal a ma upgrade featurecodeadmin
amportal a ma upgrade logfiles
amportal a ma upgrade ringgroups
amportal a ma upgrade sipsettings
amportal a ma upgrade miscapps
amportal a ma upgrade miscdests
amportal a reload

ln -s /var/lib/asterisk/moh /var/lib/asterisk/mohmp3
amportal start

just one thing i would like to add and i think there is some installation issue. as mentioned above i have been doing some research, with my very basic experience it seems like app_meetme.so is required as per the call log, which is not installed.

i try to find it via “module show like app_meetme” it result 0 files
i try to local app_meetme.so but could not find on whole system however app_confbridge.so was there and could be found on “module show”

reference to above installation.
command "make menuselect"
in application section > app_meetme is show up “XXX” at start.
these are my findings.
Thanks,
MYK

I suggest you actually go through ALL the options after make menuselect, you make it hard for yourself, if you want something and it is unavailble, then you will be clued as what dependencies need satisfying. then ./configure again and iterate.

it says dependency is Dahdi(E)
which is already installed
dpkg -l | grep dahdi
ii dahdi 1:2.2.1.1-1 utilities for using the DAHDI kernel modules
ii dahdi-linux 1:2.3.0.1+dfsg-2 DAHDI telephony interface - Linux userspace parts
ii dahdi-source 1:2.3.0.1+dfsg-2 DAHDI telephony interface - source code for kernel driver

but still “make menuselect” still shows the same XXX mean dependency.however the package is installed.

any idea?

do you think i have made a mistake installing freepbx tarball actually reason for using debian i am quite useto with the structure and using debian only OS throughout the network.

do you suggest to install it from ISO ?

Thanks,

Myk

Debian at this time will preclude you from utilizing any commercial modules, you can install using the Debian instructions in our WIKI… since you are using KVM, you can easily install using the FreePBX Distro ISO.

No, for many reasons I use Debian myself. I can assure you that it all works fine. Currently the latest dahdi complete is 2.7.7+2.7.7, I have already suggested you don’t use any deb’s , as previously stated they are all badly broken. Just take the time to compile everything yourself.

There was a time when installing incron and zenguard worked if you really needed the “commercial” add-ons free or expensive, even in that bastard Debian , are you saying that that will no longer work and you really only should install FreePBX on your version of Centos?

dicko some of them may work, some of them may have dependencies on some CentOS stuff, or specific PHP versions, or require RPM installation methods not easily supported in Debian… many people that are installing FreePBX on Debian these days are doing so on unsupported hardware, such as the Raspberry PI, which ZEND Guard doesn’t support the processor on. There are instructions on the FreePBX WIKI for installing FreePBX on Debian, I’ve not had time to play with them. http://wiki.freepbx.org/display/HTGS/Installing+FreePBX+on+Debian+Wheezy

I fully understand, It is Schmoozes choice to restrict their IP into their own territory and they have every right to do so. As long as they keep the real FreePBX open source I will continue to support that part of it. I still think you guys are slowly painting yourself into a corner though, time will tell, JM2CWAE.

Very altruistic of you to be so concerned, it will make me sleep better at night knowing you are thinking about us :wink:

The reality is, for us to protect the IP and value of the commercial code we develop for those modules, it has to be obfuscated and protected, and ZEND does that reliability well. If there was a way to ensure support for every Linux distro, or heck even every Distro that uses FreePBX already we would do it as that expands the market-base for the commercial modules, the bulk of the development time is spent on the Open Source code, but ensuring support for every variant would add time that the developers are already stretched thin on, and wouldn’t add that much more value to the end product.

That being said not everyone that takes from the project gives back, you personally spend hours per week answering questions on the forums, and freely giving back your knowledge to assist the user base, but many that use FreePBX to run their business phone systems, or even provide the platform that they sell as a product to their customers never give back in time or money. A wise man once said:

“This is just a gentle prod for you all to to actually pay a little for what you demand “for free” (and struggle sometimes vainly to understand what that true cost is) in the the true open source concept, you get what you invest in, time or money, it’s your choice.” JM2CWAE

Thanks people, i give it a last try with freepbx wiki installation. otherwise i will move to centOS.

but just a innocent question.
is there any probability, that freepbx go completely commercial as trixbox?
actually the reason for asking this is your discussion, which was quite interesting :slight_smile:

No chance what so ever, Schmooze believes in an open source FreePBX and our developers have been donating thousands of hours of development time each year towards the open source FreePBX, but the power of open source means that we aren’t the only ones…a strong community of developers, resellers, end users and enthusiast also contribute their time back into the project, with code, patches, fixes, bug reports, documentation, beta testing, responding to forum post and promoting the FreePBX Ecosystem in their business.

Thanks for clarification, i really appreciate all the contribution from all individual and wish i could also do the same like all you people are doing for this amazing app and one day definitely will.

Thanks,

sirtcp

Hi,
I have the call recording and conference modules enabled. However, in Applications --> Conference, I am unable to get the ‘Recording’ option.

I also went to Applications --> Call Recordings and created a recording with Destination - Extension --> . However, unable to find any meetme_XXX file in /var/lib/asterisk/sounds.

Need help to enable conference recording.