Operator Extension not working

I have a PiAF installation with Asterisk and FreePBX and for some reason the “Operator Extension” in the “General Settings” is not working. Usually when set, if you press “0” while listening to the voicemail message of a particular extension, you would be redirected to the extension set in “General Settings”. It can also be a ring group, queue, etc… I’ve use it on other system and it worked as expected but on this particular PBX it doesn’t. It does nothing and the voicemail message keeps going. I tried different extensions, ring groups… I thought it might be a DTMF issue, but in the IVR I can select different options without problems. I even tried to enable the VXM locator and set the “0” option to go to an extension instead of the operator extension and it doesn’t work.


There’s a setting in “Setup” -> “Voicemail Admin” -> “System Settings” (not a specific extension) and then sub-section “Settings”, that option is called “operator” and that was set to “no”. So the “Operator Extension” in the “General Settings” is useless unless the previous option is set to “yes” or maybe “undefined”.