OpenVPN Server - FPBX 13 RC1

Quick question: how do I get the “OpenVPN Server” configured so my dashboard has all those pretty green checkmarks? Do I simply have to configure it manually, or is there a module that does this? (forgive my ignorance, thank you)

There is a module, it is in beta. I think for you to see that the module probably is installed as I think that comes from a hook. @qwell may know better

This was from a fresh / stock / standard install from FBPX Distro so unless that module is installed by default, I didn’t install or enable any additional modules.

check if you’ve got the System Admin module installed, not necessarily activated/registered but just present.

I run a VM for testing and installed FreePBX 13 and it also show that OpenVPN server is not running and the only reference to VPN anything I can find in FreePBX is in the System Admin module, which I have not activated or registered the PBX as it’s just a test VM.

My live PBX does have OpenVPN running but I don’t have the System Admin module installed so it does not show the “OpenVPN server” on the dashboard.

It would be great to have options somewhere that you could select what shows in that list on the dashboard, whether you use it or not…

Yes I installed from thr SHMZ Distro ISO which comes with System Admin enabled by default - but it is not licensed. It’s ok I don’t mind seeing the Ovpn status there I just wanted to know if I was doing something wrong.

Ignore it. The VPN status in dashboard indicates (for now anyway) when the PBX is manually configured to connect to the Sangoma VPN, and is used for support access.