Online voice mail interface not working

My online voice mail interface is not working correctly any more.

I updated my system to 2.9 a couple months ago when it was released. Before the update the VM system worked fine. We could log in and listed to messages just fine. After the update it would not work (details below). I was hoping it was just a bug that would get worked out but it is now at 2.9.0.2 and the system is still not working.

Note that I did not change anything else other than update to 2.9 when it broke.

This is what it does now.

  • When I log in, I enter my extension and pw. I get to the list of messages. If I press download, it goes to a page that says file not found.

  • If I try to move the message to a different folder, it sends me to the log in page like I never loged in.

  • If I try to listen to the message, it opens up a row below the message that I tried to play but instead of displaying the play, pause, progress bar the new row just stays blank and does nothing.

Someone please help! One of my off-site phones went down today and the user has no way to check his VM.

Thanks
Russ

If I press Settings or any of the feature buttons on the left, it takes me to a login page.

Check that /var/lib/php/session is owned by asterisk for user and group

That did it. Thank you. Why did it stop working as soon as I upgraded?

I think it breaks when updating php via yum.

I bet it broke when I did an update earlier. I just didnt realize it broke until I started testing after the 2.9 update (and someone started complaining).

Thanks again!