One Way Voice

Hello,

we are having physical machine With Centos 6.4 and 2.10.0.0 FreePBX
now,
we have a sip provider with a registerd sip_trunk and it has also a media address.
when i call from this sip trunk to the outside - i can hear the person i called to but he cant hear me
and when an incoming call from this sip trunk goes in
i can hear the outside person and he cant hear me.

when i made rtp sniffing i can see rtp going both ways to correct address
and when our firewall guy checkd he can see rtp both ways go throw.

this machine has 2 network cards
both internal 1 for PRI and another one.

we have set a static external ip on pbx & firewall settings for sip trunks.
now beside this provider we have another provider that all calls go throw fine with RTP

do you have some suggestion to check ?
because we do see RTP packages go throw but there is one way voice.

Thanks.

Check the NAT settings for your SIP trunk that doesn’t work. I’m going to guess your network addresses aren’t correct or your NAT settings are just not right.

The lack of specifics on your description makes it confusing for us to understand what you’re talking about, especially when you throw in the part about one of your network cards being connected to a PRI ???

The fact that you have two providers means that the configuration for the other provider is correct in both the PBX and the router. Make sure your firewall settings, routing tables, and PBX settings.

You stated your PBX has a static IP? You are checking in the following scenario:

SIP EXT (on LAN and NATing) --> FreePBX (static IP) --> SIP provider?

In that case, you should enable NAT for the Extension too.

You have two ethernet cards and the one is connected to a pri gateway or a pri card and an ethernet card. Both have rj45 ports but do different things.

Check your box and post what settings you have in all your sip trunks and what nat settings you have in general sip options.

i tried to enable NAT at the extention but it didnt work - NAT is enabled at the sip_nat.conf.

this is the one way voice provider settings :
type=friend&peer
relaxdtmf=yes
qualify=yes
port=5060
nat=yes
insecure=port,invite
host=XXX.XXX.XXX.XXX
from-user=XXXXX
dtmfmode=auto
disallow=all
;allow=alaw
allow=g729&alaw&ulaw

advenced sip settings:
NAT=YES
Static IP :xxx.xxx.xxx.xxx
codecs ulaw,alaw,gsm

working providers sip trunks :
user=phone
type=friend
relaxdtmf=yes
qualify=yes
outboundproxy=xx.x.x.x
nat=yes
insecure=port,invite
host=xx.x.x.x
fromdomain=xx.x.x.x
dtmfmode=inband
disallow=all
context=from-Bezeq
canreinvite=no
allow=alaw

or :
type=peer
host=sip.de.xxxxx
nat=yes
username=xxxxx
secret=xxxxx
qualify=yes
allow=ulaw

and my 2 network cards :

DEVICE=em1
BOOTPROTO=none
NM_CONTROLLED=yes
ONBOOT=yes
TYPE=Ethernet
PREFIX=23
DNS1=192.168.11.235
DNS2=192.168.11.236
DEFROUTE=yes
IPV4_FAILURE_FATAL=yes
IPV6INIT=no
NAME="System em1"
USERCTL=no
IPADDR=192.168.11.230
NETMASK=255.255.254.0
GATEWAY=192.168.11.254

DEVICE=em2
BOOTPROTO=none
NM_CONTROLLED=yes
ONBOOT=yes
TYPE=Ethernet
IPV6INIT=no
USERCTL=no
IPADDR=192.168.1.10
NETMASK=255.255.255.0

Each ethernet card is for each sip provider? If yes then I am guessing that you have to fix your routing table. Now everything goes out the first ethernet card. If this is the case run the command route and post here what you get.

no-
again this is only internal address
we have the firewall giving the static external addres so this network cards does not related.

the sip provider send calls to the external address

What do you mean internal use, why you have two ethernet cards on it, please explain.

as i understand one is for extensions and internal connection and one for the PRI
anyways- our firewall guy solved it so it was firewall issue there - i dont know extectly what it was but i understood it
was working as a fail-over and now its not.

anyway thanks, solved.