One way voice for some call attempts

I have a setup as follows

Linphone (PJSIP) —> Internet —> (Public IP) Huawei HG8245H. (DMZ and UPD forwarded to FreePBX) —> FreePBX ( chan-dongle)

I have linphone with UDP connection to the public IP of the router Huawei.

Huawei router is configured with DMZ to ie. RPi FreePBX server. Also 5060 UDP and 10000 - 20000 UDP is forwarded to

In FreePBX Nat is not enabled.

When I call using linphone, other end phone can’t hear my voice and I can hear their voice. Mostly this happens when I call first time. But second time call works normally. Sometimes I have to dial several times to get two-way voice working.

I tired to set NAT etc. But none worked. Appreciate your help.


Try recording the call on FreePBX, to see whether the Linphone -> PBX or the PBX -> PSTN path is failing.

Linphone device (Android, Windows, Linux, etc.)? How connected to internet (Wi-Fi, Ethernet, mobile data)? If not mobile data, make/model of router/firewall? Is Linphone on the same network as the PBX? If not, do you still have trouble when it is on the same network?

If you call *43 (echo test) from Linphone, does that work reliably?

Thank you!

*43 echo test work and I can hear my voice.

Recording enabled then I couldn’t hear anything and made them off.

Also to make a model within LAN, I have no physical access since I am in a different county now. Can we get any clue from asterisk terminal? From Linphone end, I tried with wifi and 4G, but no success.

Part of asterisk log:

-- Dongle/dongle0-0100000005 is making progress passing it to PJSIP/001-00000005
   > 0x73e26628 -- Strict RTP learning after remote address set to:
   > 0x73e26628 -- Strict RTP qualifying stream type: audio
   > 0x73e26628 -- Strict RTP switching source address to
   > 0x73e26628 -- Strict RTP learning complete - Locking on source address
-- Dongle/dongle0-0100000005 answered PJSIP/001-00000005

Best regards,


This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.