One Way Audio with SSLVPN in Sophos XG

Hello!

we just got a FreePBX Sangoma appliance.

We are having a problem with the users conected to our VPN, they can register to the internal IP of the PBX in the DMZ, but we cannot send audio tothe PBX, we can just recieve. In our wiresharks it shows that the PBX estabilishes a connection with his Private IP, but then the client sends audio to the Public IP for some reason.

Anyone has experience with that problem? all the ports are open on the two ways.

IPS:

192.168.250.0 -> PBX on the DMZ
10.200.250.0 -> VPN cliente
172.20.0.0 -> Local Lan Network

Add the VPN subnet to Settings, Asterisk SIP Settings, local networks. If using pjsip it may require an asterisk restart.

Another piece to check is what address the PBX is sending to the phone to “reply” to.

Do what Lorne said first and see if that helps. If the PBX is telling the phone to use the public path, then that should fix it. If the phone is still sending the audio to the public port after that, turn off NAT on the extension and on the phone (since it should be on the “local” VPN network) and should be able to talk directly to the PBX over the connection.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.