One way audio via SIP

Hello,

I have a FreePBX 2.7.0.10 with Asterisk 1.4.24 using the x386 version AsteriskNOW. There are 4 analog lines plugged in and working fine. Since I have nothing but analog lines when the system performs an afterhours call forward the volume drops to an insanely low level. I have attempted to increase the GAIN value which helped some but not enough. All of that led me to adding a single SIP line as my outbound trunk for call-forwards (via Misc Destinations). I purchased a SIPStation line as a way of paying back the FreePBX guys for their effort. I can make outbound calls and the end caller can hear me but I have cannot hear anything from them.

I’ve searched around and everything points to the firewall blocking. I opened port 5060 and ports 10000-20000 for UDP and directed them to my PBX. Later I found a reference to the sip_nat.conf and updated that but still no go. I am using a Cisco (Linksys) RV042 firewall router.

  • I found a horrible article at http://forums.digium.com/viewtopic.php?t=7854 that said to open (basically) everything, please don’t follow that, maybe it was accurate due to the age of the post or maybe its been deprecated through updates
  • I found references to sip-nat.conf and sip_nat.conf, I believe the correct version is sip_nat.conf
  • at PBXinaFlash their example shows configuring Port Triggering/Application, tried that with no results
  • on the FreePBX> SIPstation module page the Run Firewall Test shows PASS
  • on the FreePBX> SIPstation module page the Asterisk Reg shows Registered but the Network IP and Contact IP show Undefined
  • since I am using sip_nat.conf I do not believe I need to use the Asterisk Sip Settings module - correct?

sip_nat.conf

[[email protected] asterisk]# more /etc/asterisk/sip_nat.conf
externalip=x.x.x.x (obviously hiding my true IP address)
localnet=10.12.100.0/255.255.255.0
nat=yes

You do not need to open the ports up, the router will do then when the registration is done.

Please post the IP settings result of the command “sip show settings” in asterisk.

Yes, install the sip configuration module and don’t bother with sip_nat.conf.

No need for posting the results, as soon as I added the Asterisk Sip Settings module things started working. I appreciate the help (again).

I deleted the firewall port forwardings and the SIPstation now shows FAIL on the Firewall Test. I rebooted the PBX to make sure things still work and they do.

Can you explain a big picture question? Is that module always needed for any SIP implementation? I never saw a reference to that in the SIPstation FAQ and or any forum. I deleted the contents of sip_nat.conf because of the warning message when I installed/updated the Asterisk Sip Settings module. When I looked at it afterwards (once the system was working) the file is still blank.

You either not reloaded since you updated sip_nat.conf or you had a syntax error in the file.

The modifications from the sip module are in sip_general_additional.conf if you want to take a peek.

Does your audio work without the firewall forwarding? If it does ignore the firewall warning. The open ports create a security risk and unless you are using a remote phone port forwarding is not needed.

I bet I did not reload the sip after the changes.

I checked the sip_gen… and see my sip_nat values along with a bunch of other values set. Thanks for the pointing.

New issue though
I have a VPN between the office (where the ‘test’ PBX is) and my home office. I also have a standard house/analog line used just for testing at my home, a simple phone installed, no VoIP anything on it. Previously my home office could dial out and receive calls fine through the office PBX. Now if I leave the SIPstation as my first outbound trunk and dial from my home office through the PBX I 1) hear no audio on either side 2) the remote receiver can hang up but the home office VoIP phone stays connected.

If I change the outbound trunk so my ZAP g0 (3 office analog lines going to a 4 port FXO A400P) is first then I cannot hear the other side audio but the caller can hear me fine. Basically the same issue I was having with the SIPstation but on the analog side.

The original problem is staying fixed, I can call into the office and call forward out to my cell phone over the SIPstation line with audio working fine.

  • I don’t see the need to open ports on the firewall since a VPN is working fine, which means my traffic should flow un-hindered
  • is there a special setup I’m missing by trying to run SIP and analog trunks together?