One way audio google compute engine

I have installed freepbx on Centos 7 in the google cloud… (was cheaper than amazon) everything works except I get one way audio. SIP station passes firewall test…
I have a static external IP and opened up firewall ports 5060-5061 and 10000-20000
Cant figure it out…

Hello. Did you ever sort this out as I am having the same problem with Google cloud? One way audio.

What direction?

Thank you for replying. Can hear and send on external landline but the (SIP) phone registered to the extension does not receive audio but does send back to the landline.


So I call your number, the PBX sends the call to your phone. When the call starts, I can hear you but you can’t hear me? Is that the scenario?

If that is the case then the issue is the NAT where the phone is located not with the PBX.

Yes, that is the scenario. And thank you btw for responding. I’ll check my settings.

Kind regards,


Thanks again both for coming back to me.

Having focused my attentions on the client side I noticed the STUN server wasn’t set so set this and now I have two way bidirectional audio.
Kind regards,