FreePBX | Register | Issues | Wiki | Portal | Support

One extension is stuck in the busy state, dnd is not on

bug
asterisk
Tags: #<Tag:0x00007f749ee9e980> #<Tag:0x00007f749ee9e700>

(Canada) #1

We have one extension on our freepbx server, 1217, that seems to be in a permanent busy state. I’ve tried the asterisk cli command “database del dnd 1217”, I’ve tried deleting the extension and recreating, I’ve tried different phones, I’ve tried different slots on our spa500s console just in case it was a faulty lamp.

Attached is an image of the spa500s bottom is the red indicator in the stuck busy position, setting up this device was how I discovered the problem.

There must be a command to clear this stubborn busy state.

Any ideas?


(Canada) #2

Im trying to post core show hints, but im not allowed to post pastebin links and it thinks im mentioning people if i paste the whole thing -_-


(Canada) #3

Okay here it is, any help would be much appreciated.


(Jared Busch) #4

Put this on your PBX

Call it from command line

#see the satatus
sudo -u asterisk php lgaetz-dnd.php show 1217

#toggle status
sudo -u asterisk php lgaetz-dnd.php toggle 1217

(Canada) #5

Had to change the syntax a little to get it to work, however the first command returns this:

[root@server ~]# php lgaetz-dnd.php show 1217
DND Disabled

Just like any other extension we have that doesn’t have the problem.


(system) closed #6

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.