Onboard lan

I have been brutally forced to go wireless :frowning:
I recently purchased a wireless usb adapter and got
it working on my server. Is there a way to get your
onboard lan to pick up wifi so i can plug my phone into that jack
or will i need a network card and will it detect exising wireless
that the computer has running?

Thanks

how have i built a tolerant group of interface?

That is an OS/networking thing, google for network bridging on Centos.

Don’t expect anything to be automatically detected.

I don’t understand what you mean by “onboard LAN” if you have the wireless recognized then you can configure an IP address to the interface.

thanks i will google for more info

What exactly are you looking for? Setting IP address in Linux (CentOS version) is not obfuscated.

I should ask the basics, how do you know that the system recognized the wireless card?

the wireless would have to be reconized because im using the internet on it now with out a hard line connection to the router
and get this wlan0
Link encap:Ethernet HWaddr 08:10:76:C4:A8:BF
inet addr:10.0.0.XXX Bcast:10.0.0.255 Mask:255.255.255.0
inet6 addr: fe80::a10:76ff:fec4:a8bf/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:4209 errors:0 dropped:10180 overruns:0 frame:0
TX packets:3781 errors:0 dropped:1 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:3931977 (3.7 MiB) TX bytes:718521 (701.6 KiB)

Exception while fetching information for ETh0: [Ernno 99]cannot assign requested address

I only have one onboard lan slot as of now that i would like to dedicate to the phone. but i’m not sure if its for input only. Thats why i was asking if i need
to buy a network card to have lan output to the phone.
Correct me if i’m wrong about this.

sorry
[onboard lan]
is old term for integrated on the motherboard as apposed to pci card or other types of removable cards.

My labtop has the samething and when connected the phone works after a reboot
to resolve conflicting ip.
I dont know anything about labtop hardware nor think i can compare the two ethernet slots to function the same?
Usb is wide open on my desktop if there is a easy solution that way

I know what that reference is, it doesn’t really matter what bus the network adapter is attached to.

I don’t understand what a “input only” interface would be, all Ethernet interfaces are bi-directional and most full-duplex (needed for quality voice).

I assume you installed Asterisk and FreePBX on an existing Linux system? You are surfing the Internet on the same system FreePBX and Asterisk are running on?

You should be able if this is the case to reach the site via the loopback address http://127.0.0.1/admin/config.php

If you know how to pull all this info do you not know how to set an ip address on an interface? By default Asterisk binds to all interfaces.

Is the error you are receiving look like the one below?

If it is this is whatever program the FreePBX runs each time you log in. It appears that this program throws an error if there is no IP address assigned to a network interface. The system below has 3 interfaces ETH0 and ETH1 are physical Ethernet interfaces and TUN0 is a VPN interface. ETH1 is not being used and has no IP assigned.

Exception while fetching interface information for eth1: [Errno 99] Cannot assign requested address

| | __ ___ | _ | __ ) / /
| |
| '
/ _ / _ \ |
) | _ \ /
| || | | __/ __/ __/| |) /
|
| |
| _|_|| |__//_\

Interface eth0 IP: 10.48.15.158
Interface eth1 IP: No IP
Interface tun0 IP: 10.8.0.57

Please note most tasks should be handled through the FreePBX UI.
You can access the FreePBX GUI by typing one of the above IP’s in to your web browser.
For support please visit http://www.freepbx.org/support-and-professional-services

yes the above is the exact error i get.
no i dont know how to set an ip address on an interface? By default Asterisk binds to all interfaces.
yes i can access http://127.0.0.1/admin/config.php
is it bad to surf the web with the same pc? or just not recommended? help to set an ip address on an interface would be good
I did not know they were bi-directional, thats good.

Below is a link that talks about channel bonding interface,

http://www.centos.org/docs/5/html/Deployment_Guide-en-US/s1-networkscripts-interfaces.html#s2-networkscripts-interfaces-chan

Am i on the right page to begin here and bond eth0 to wlan?

Reading further what you are trying to do then use bridging not bonding or do the Skyking thing and just add an address to eth0 and let asterisk do the bridging.

hi Dicko
Im getting ready to edit vi /etc/sysconfig/network-scripts/ifcfg-eth0

which is currently

#Configuration automatically generated via the PBXact Utility
#DO NOT HAND MODIFY THIS FILE!
#generated: Fri, 01 Mar 2013 23:33:15 -0500
DEVICE=eth0
BOOTPROTO=dhcp
ONBOOT=yes

changing to:
vi /etc/sysconfig/network-scripts/ifcfg-eth0

DEVICE="eth0"
HWADDR="00:21:70:10:7E:CD"
NM_CONTROLLED="no"
ONBOOT="yes"
BOOTPROTO=static

BOOTPROTO=dhcp

IPADDR=10.16.1.106
NETMASK=255.255.255.0
GATEWAY=10.16.1.1

Is that right?
can i modify or will PBXact Utility have issue with manual modifacation?

I don’t know I don’t use PBXact. Try it and see ?

Some of the commercial modules need the name updated. PBXaxt is the closed source product.

I think i may be making a little progress.
It looks like eth0 is bonded but the phone still waits network to initialize.
I followed these steps.

created /etc/sysconfig/network-scripts/ifcfg-bond0
DEVICE=bond0
NETMASK=255.255.255.0
ONBOOT=yes
BOOTPROTO=none
USERCTL=no
NAME="System bond0"
NM_CONTROLLED=no
IPADDR=10.0.0.7
MII_NOT_SUPPORTED=yes

created /etc/modprobe.d/bonding.conf
alias bond0 bonding
options bond0 mode=1 miimon=100

modfied /etc/sysconfig/network-scripts/ifcfg-eth0

DEVICE=eth0
USERCTL=no
MASTER=bond0
SLAVE=yes
BOOTPROTO=none
NAME=eth0
ONBOOT=yes
NM_CONTROLLED="no"
MII_NOT_SUPPORTED=yes

then ran

modprobe bonding

ifconfig bond0 up

ifenslave bond0 eth0 eth1

bond0 Link encap:Ethernet HWaddr 00:13:D3:A2:BE:83
inet addr:10.0.0.7 Bcast:10.0.0.255 Mask:255.255.255.0
inet6 addr: fe80::213:d3ff:fea2:be83/64 Scope:Link
UP BROADCAST RUNNING MASTER MULTICAST MTU:1500 Metric:1
RX packets:16 errors:0 dropped:0 overruns:0 frame:0
TX packets:42 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:7822 (7.6 KiB) TX bytes:6484 (6.3 KiB)

eth0 Link encap:Ethernet HWaddr 00:13:D3:A2:BE:83
inet addr:10.0.0.7 Bcast:10.0.0.255 Mask:255.255.255.0
UP BROADCAST RUNNING SLAVE MULTICAST MTU:1500 Metric:1
RX packets:16 errors:0 dropped:0 overruns:0 frame:0
TX packets:42 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:7822 (7.6 KiB) TX bytes:6484 (6.3 KiB)
Interrupt:20 Base address:0xe000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:374 errors:0 dropped:0 overruns:0 frame:0
TX packets:374 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:40510 (39.5 KiB) TX bytes:40510 (39.5 KiB)

wlan0 Link encap:Ethernet HWaddr 08:10:76:C4:A8:BF
inet addr:10.0.0.181 Bcast:10.0.0.255 Mask:255.255.255.0
inet6 addr: fe80::a10:76ff:fec4:a8bf/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:8098 errors:0 dropped:14144 overruns:0 frame:0
TX packets:8324 errors:0 dropped:2 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:6757092 (6.4 MiB) TX bytes:2668031 (2.5 MiB)
then

[[email protected] network-scripts]# cat /proc/net/bonding/bond0
Ethernet Channel Bonding Driver: v3.6.0 (September 26, 2009)

Bonding Mode: fault-tolerance (active-backup)
Primary Slave: None
Currently Active Slave: eth0
MII Status: up
MII Polling Interval (ms): 100
Up Delay (ms): 0
Down Delay (ms): 0

Slave Interface: eth0
MII Status: up
Speed: 100 Mbps
Duplex: half
Link Failure Count: 0
Permanent HW addr: 00:13:d3:a2:be:83
Slave queue ID: 0

then
[[email protected] network-scripts]# service network restart
Shutting down interface bond0: [ OK ]
Shutting down interface wlan0: ERROR : [ipv6_test_device_status] Missing parameter ‘device’ (arg 1)
[ OK ]
Shutting down loopback interface: [ OK ]
Bringing up loopback interface: [ OK ]
Bringing up interface bond0: [ OK ]
Bringing up interface wlan0: Device does not seem to be present, delaying initialization.
[FAILED]

so when i click system bond0 in menu network connections a message pop up displays connection establised. the phone not connecting yet!
below are some var log messages may help you help me

Mar 28 03:25:53 PlcmSplp dhcpd: For info, please visit https://www.isc.org/software/dhcp/
Mar 28 03:25:53 PlcmSplp dhcpd: /etc/dhcp/dhcpd.conf line 6: semicolon expected.
Mar 28 03:25:53 PlcmSplp dhcpd: option domain-name â<80>
Mar 28 03:25:53 PlcmSplp dhcpd: ^
Mar 28 03:25:53 PlcmSplp dhcpd: bad range, address 255.0.0.0 not in subnet 255.255.181.0 netmask 255.255.255.0
Mar 28 03:25:53 PlcmSplp dhcpd:
Mar 28 03:25:53 PlcmSplp dhcpd: This version of ISC DHCP is based on the release available
Mar 28 03:25:53 PlcmSplp dhcpd: on ftp.isc.org. Features have been added and other changes
Mar 28 03:25:53 PlcmSplp dhcpd: have been made to the base software release in order to make
Mar 28 03:25:53 PlcmSplp dhcpd: it work better with this distribution.
Mar 28 03:25:53 PlcmSplp dhcpd:
Mar 28 03:25:53 PlcmSplp dhcpd: Please report for this software via the CentOS Bugs Database:
Mar 28 03:25:53 PlcmSplp dhcpd: http://bugs.centos.org/
Mar 28 03:25:53 PlcmSplp dhcpd:
Mar 28 03:25:53 PlcmSplp dhcpd: exiting.
Mar 28 03:26:04 PlcmSplp kernel: IW_SCAN_THIS_ESSID, ssid=HOME-AC52, len=9
Mar 28 03:26:04 PlcmSplp kernel: issue_nulldata:1
Mar 28 03:26:05 PlcmSplp kernel: issue_nulldata:0
Mar 28 03:26:05 PlcmSplp kernel: survey done event(0x25)
Mar 28 03:26:35 PlcmSplp kernel: bonding: bond0: Removing slave eth0
Mar 28 03:26:35 PlcmSplp kernel: bonding: bond0: releasing active interface eth0
Mar 28 03:26:36 PlcmSplp NetworkManager[1538]: (eth0): carrier now OFF (device state 8, deferring action for 4 seconds)
Mar 28 03:26:36 PlcmSplp avahi-daemon[1559]: Withdrawing address record for 10.0.0.7 on eth0.
Mar 28 03:26:36 PlcmSplp avahi-daemon[1559]: Leaving mDNS multicast group on interface eth0.IPv4 with address 10.0.0.7.
Mar 28 03:26:36 PlcmSplp avahi-daemon[1559]: Interface eth0.IPv4 no longer relevant for mDNS.
Mar 28 03:26:36 PlcmSplp avahi-daemon[1559]: Withdrawing address record for 10.0.0.7 on bond0.
Mar 28 03:26:36 PlcmSplp avahi-daemon[1559]: Leaving mDNS multicast group on interface bond0.IPv4 with address 10.0.0.7.
Mar 28 03:26:36 PlcmSplp avahi-daemon[1559]: Interface bond0.IPv4 no longer relevant for mDNS.
Mar 28 03:26:36 PlcmSplp avahi-daemon[1559]: Withdrawing address record for fe80::213:d3ff:fea2:be83 on bond0.
Mar 28 03:26:37 PlcmSplp kernel: lo: Disabled Privacy Extensions
Mar 28 03:26:37 PlcmSplp kernel: ADDRCONF(NETDEV_UP): bond0: link is not ready
Mar 28 03:26:37 PlcmSplp kernel: 8021q: adding VLAN 0 to HW filter on device bond0
Mar 28 03:26:37 PlcmSplp kernel: bonding: bond0: Adding slave eth0.
Mar 28 03:26:37 PlcmSplp kernel: eth0: link up, 100Mbps, half-duplex, lpa 0x40A1
Mar 28 03:26:37 PlcmSplp kernel: bonding: bond0: making interface eth0 the new active one.
Mar 28 03:26:37 PlcmSplp NetworkManager[1538]: (eth0): carrier now ON (device state 8)
Mar 28 03:26:37 PlcmSplp kernel: bonding: bond0: first active interface up!
Mar 28 03:26:37 PlcmSplp kernel: bonding: bond0: enslaving eth0 as an active interface with an up link.
Mar 28 03:26:37 PlcmSplp kernel: ADDRCONF(NETDEV_CHANGE): bond0: link becomes ready

I understand this may be a seperate issue but i get this failure when
i [[email protected] network-scripts]# /etc/init.d/dhcpd restart
Starting dhcpd: [FAILED]

last but not least a kernel panic has accured once # ifenslave bond0 eth0 wlan was ran and sometimes
when i manually shut down a network. I’m doing some reading here http://www.novell.com/support/kb/doc.php?id=7004798
and was wondering if someone can suggest a propper bonding driver upgrade
that seems to be available above to eleminate the kernel panic

Thanks

Wow, that’s possibly the most work I have ever seen anyone do that was counter productive.

I have not idea what you are doing. You have somehow built a fault tolerant group of the wireless interface?

Why did you simply not assign another IP to the Interface?

I tried but simply adding ip didnt seem to work
even after running ifconfig eth0 up, i get no carrier next to broadcast

For some reason… I have found myself in the same boat…
I have deployed several freepbx units with multiple ethernet interfaces. Each one is quite unique.
Then I decided to install from the latest “iso”. Big mistake so far.
I configured my system propper before every touching the freepbx guis. With the freepbx guis- I went from a perfect ifcfg-eth0/ifcfg-eth1 to a useless ifcfg-eth0 which has crippled my machine. I am unable to “add” an eth1 through the freepbx gui. after flushing freepbx, reconfiguring unix… … now I am foreced to “chroot” "/"etc/sysconfig/network-scripts so the freepbx gui can exercise its godlike dominion over my netstack without killing my box. What a serious time cost to me and those whos arms are folded, looking at thier watches and tapping their feet. I played this game before and should have remembered.
Next time:
After the box is functional from a networking point of view and I can remotely admin the box:::

sudo /usr/bin/chattr +i /etc/sysconfig/network-scripts/ifcfg-eth*

Let the overlord try to figure out why he can’t brick my box.
:slight_smile: