Official Distro with asterisk 13 and Asterisk 13 borked on AWS

I apologize if this is not the place to post this. I was not sure of the best spot.

I am reporting this just to report it as much as anything else.

I use FreePBX (official distro) in Amazon AWS by way of VM imports. This has worked fine for me for a year or more. V11 and V12 worked great but I am having some issue with V13.

I tested this several times and it seems that this is the case. If I do an import of a working VM on V13 with Asterisk 13 and I crank that puppy up I will see am Error in the web interface saying “cannot connect to asterisk”. If I log into the CLI via SSH it also complains and asks that an FWCONSOLE command be run. Something like fwconsole -zend_fix I think. Once I do that Asterisk will come back to life but then I have all sorts of issues with the box from that point on.

Now if I do this same process with v13 but with Asterisk 11 everything seems to run just fine. So of course for now I am just using v13 with Asterisk 11.

Again just thought I would report this just in case it helps anyone or helps development (not sure if you guys care about AWS or not).


what sorts of issue with you have when you run the fwconsole -zend_fix command?

will it help if you set asterisk to start at boot?

  1. chkconfig --level 345 asterisk on