Odd behavor after Applying Config


So recently when ever I apply the config from the Web Control Panel the server starts doing a ton of these calls:

== Spawn extension (tc-maint, s, 6) exited non-zero on 'Local/[email protected];2' -- Executing [[email protected]:1] NoCDR("Local/[email protected];2", "") in new stack -- Executing [[email protected]:2] Set("Local/[email protected];2", "TCMAINT=RETURN") in new stack -- Executing [[email protected]:3] GosubIf("Local/[email protected];2", "0?timeconditions,2,1()") in new stack -- Executing [[email protected]:4] GosubIf("Local/[email protected];2", "0?timeconditions,1,1()") in new stack -- Executing [[email protected]:5] System("Local/[email protected];2", "/var/lib/asterisk/bin/schedtc.php 60 /var/spool/asterisk/outgoing 1") in new stack -- Attempting call on Local/[email protected] for application NoCDR() (Retry 1) -- Executing [[email protected]:6] Answer("Local/[email protected];2", "") in new stack

I even let it run for a good hour and it finally stopped doing this when I restarted asterisk. The 0000098c part increments with each entry in the log.

I’m not sure what this is or how to resolve it. Any help is greatly appreciated.

My FreePBX version is, Asterisk

Are you using time conditions? If not, try removing it, along with any other modules you aren’t using. It will simplify your dialplan and possibly stop this, whatever it is.

I am using time conditions with 2.10 and haven’t seen any behaviour like that.

This is what you get in the log if you have a time condition with “Generate BLF Hint” enabled. You have to choose between clean logs or Time Condition hints.

Actually, I might be wrong about this, you might get the log activity with any time condition.

Yes I have I do have Time Conditions to use a different IVR for during and not during office hours.

The “Generate BLF Hint” is turned off for each time condition.