FreePBX | Register | Issues | Wiki | Portal | Support

Obvious NAT Issue...but why?


#1

So I’m familiar with typical no audio NAT issues (I say familiar loosely, I’ve definitely done some community search in the past to overcome). But this one has me a little baffled.

I have a FreePBX installation running on a VPS with a public IP attached to it running responsive firewall.
Using 1 SIP truck
There are 3 phones configured, all of which connect to the PBX with no issues using Chan_SIP driver.
All phones are various Grandstream models
2 phones are at 1 remote location (call it Location 1, with extensions 201 and 202), the other phone is at a second location (Location 2 with extension 203).
All extensions can place or receive calls from the trunk with no issues, 2 way audio works great.
However, if any of the extensions try to call each other then there is only 1 way (or no audio).
At location 1 If extension 201 and 202 try to talk to each other, 202 can hear 201 talking, but 201 cant hear 202 talking. If 201 has a call with 203 (two different locations now) then 203 can hear 201 but 201 hears nothing. If 202 and 203 have a call, theres no audio at all in either direction.

I did some pack captures from one of the phones. It seems that the traffic is trying to direct straight to the external IP address of each phone rather then going through the PBX… perhaps this is a misunderstanding on my side as I always assumed that the RTP traffic would route through the PBX first. Either way, Im stuck with this situation now and dont really know where to proceed next. I can port forward at each location, but at the location with 2 devices (with potential of more down the road) Im not sure what the solution would be as I can only forward rtp ports to one device at time.

I figured this is a fairly common setup (single PBX with remote extensions) so Im sure its something simple im missing here :expressionless:


(Dave Burgess) #2

I have a similar problem with my installation. I use a local server behind a firewall that redirects all SIP traffic to the SIP server. If I try to call any of my DIDs from my phone server and use my external connection I get no audio. Everything is set up correctly for NAT, but because of the “blunt object” nature of my setup, I end up NATting myself into a black hole.

For these phones, I use a different outbound provider and send the call to them, which routes the inbound call to my inbound provider, which alleviates the problem (there are other advantages as well, but that’s the reason I set it up in the first place).

The server should be routing all of your NTP traffic locally unless you have “direct_media” (in its various forms) turned on. There has been a flurry of people discussing PJ-SIP Direct Media settings here - the latest was last week. It’s possible that you are seeing this peculiarity of PJ-SIP in action.


(system) closed #3

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.