"Number not answering" but only a specific number?

Hello everyone ! My probleme is, when i try outgoing call, it work fine.
But, one specific number don’t work, and FreePBX tell me the number is not answering.

FreePBX 15.0.17.24


-- Executing [[email protected]:9] ExecIf("PJSIP/ORANGE-OBS1-00005382", "0?Set(sipheader=<http://127.0.0.1>;info=unset)") in new stack
-- Executing [[email protected]:10] ExecIf("PJSIP/ORANGE-OBS1-00005382", "0?Set(sipheader=<http://127.0.0.1>unset)") in new stack
-- Executing [[email protected]:11] ExecIf("PJSIP/ORANGE-OBS1-00005382", "0?SIPAddHeader(Alert-Info:unset)") in new stack
-- Executing [[email protected]:12] ExecIf("PJSIP/ORANGE-OBS1-00005382", "0?Set(PJSIP_HEADER(add,Alert-Info)=unset)") in new stack
-- Executing [[email protected]:13] EndWhile("PJSIP/ORANGE-OBS1-00005382", "") in new stack
-- Executing [[email protected]:5] While("PJSIP/ORANGE-OBS1-00005382", "0") in new stack
-- Executing [[email protected]:14] Return("PJSIP/ORANGE-OBS1-00005382", "") in new stack

== Spawn extension (from-pstn, 0438022400, 1) exited non-zero on ‘PJSIP/ORANGE-OBS1-00005382’
– PJSIP/ORANGE-OBS1-00005382 Internal Gosub(func-apply-sipheaders,s,1(1)) complete GOSUB_RETVAL=
– Called PJSIP/[email protected]
– PJSIP/ORANGE-OBS1-00005382 is ringing
– PJSIP/ORANGE-OBS1-00005382 is ringing
– No one is available to answer at this time (1:0/0/0)
– Executing [[email protected]:35] NoOp(“PJSIP/160-00005381”, “Dial failed for some reason with DIALSTATUS = NOANSWER and HANGUPCAUSE = 19”) in new stack
– Executing [[email protected]:36] GotoIf(“PJSIP/160-00005381”, “0?continue,1:s-NOANSWER,1”) in new stack
– Goto (macro-dialout-trunk,s-NOANSWER,1)
– Executing [[email protected]:1] NoOp(“PJSIP/160-00005381”, “Dial failed due to trunk reporting NOANSWER - giving up”) in new stack
– Executing [[email protected]:2] Progress(“PJSIP/160-00005381”, “”) in new stack
– Executing [[email protected]:3] Playback(“PJSIP/160-00005381”, “number-not-answering,noanswer”) in new stack
> 0x3433d40 – Strict RTP learning after remote address set to: 192.168.1.120:5016
– <PJSIP/160-00005381> Playing ‘number-not-answering.ulaw’ (language ‘fr’)
> 0x3433d40 – Strict RTP switching to RTP target address 192.168.1.120:5016 as source
– Executing [[email protected]:4] Congestion(“PJSIP/160-00005381”, “20”) in new stack
== Spawn extension (macro-dialout-trunk, s-NOANSWER, 4) exited non-zero on ‘PJSIP/160-00005381’ in macro ‘dialout-trunk’
== Spawn extension (from-internal, 0438022400, 13) exited non-zero on ‘PJSIP/160-00005381’
– Executing [[email protected]:1] Macro(“PJSIP/160-00005381”, “hangupcall”) in new stack
– Executing [[email protected]:1] GotoIf(“PJSIP/160-00005381”, “1?theend”) in new stack
– Goto (macro-hangupcall,s,3)
– Executing [[email protected]:3] ExecIf(“PJSIP/160-00005381”, “0?Set(CDR(recordingfile)=)”) in new stack
– Executing [[email protected]:4] Hangup(“PJSIP/160-00005381”, “”) in new stack
== Spawn extension (macro-hangupcall, s, 4) exited non-zero on ‘PJSIP/160-00005381’ in macro ‘hangupcall’
== Spawn extension (from-internal, h, 1) exited non-zero on ‘PJSIP/160-00005381’
– PJSIP/160-00005381 Internal Gosub(crm-hangup,s,1) start
– Executing [[email protected]:1] NoOp(“PJSIP/160-00005381”, “Sending Hangup to CRM”) in new stack
– Executing [[email protected]:2] NoOp(“PJSIP/160-00005381”, “HANGUP CAUSE: 34”) in new stack
– Executing [[email protected]:3] ExecIf(“PJSIP/160-00005381”, “0?Set(__CRM_VOICEMAIL=)”) in new stack
– Executing [[email protected]:4] NoOp(“PJSIP/160-00005381”, “MASTER CHANNEL: 1660633773.64353 = 1660633773.64353”) in new stack
– Executing [[email protected]:5] GotoIf(“PJSIP/160-00005381”, “0?return”) in new stack
– Executing [[email protected]:6] Set(“PJSIP/160-00005381”, “__CRM_HANGUP=1”) in new stack
– Executing [[email protected]:7] AGI(“PJSIP/160-00005381”, “agi://127.0.0.1/sangomacrm.agi”) in new stack
– <PJSIP/160-00005381>AGI Script agi://127.0.0.1/sangomacrm.agi completed, returning 0
– Executing [[email protected]:8] Return(“PJSIP/160-00005381”, “”) in new stack
== Spawn extension (from-internal, h, 1) exited non-zero on ‘PJSIP/160-00005381’
– PJSIP/160-00005381 Internal Gosub(crm-hangup,s,1) complete GOSUB_RETVAL=
3ci*CLI>

Please use the full log, not a screen scrape, and please post logs to pastebin.freepbx.org, or failing that, mark them up as pre-formatted text.

The full log contains timestamps which would confirm the length of time between Dial and failure, however there is little doubt in my mind that the number was successfully called but did not answer, and this is a straightforward no answer case,.

I can join the number with my personnal phone :confused:

The call is shown as ringing, indicating that the provider is claiming the call has reached the destination. Having the timing would tell whether Asterisk was timing it out, and having the “pjsip set logger on” output would confirm that, and if the provider was reporting no answer, might given more of their reasons.

Ok thanks, the pastebin for the pjsip logger
https://pastebin.freepbx.org/view/b5e217a7

It’s rather a small extract, and you still seem to be screen scraping, but the provider has said that the callee is temporarily unavailable:

https://pastebin.freepbx.org/view/b5e217a7#L25

Which is defined here:

https://www.rfc-editor.org/rfc/rfc3261.html#section-21.4.18

They have provided no reason header to make things clearer.

Note that, as there seems to be more than one transaction captured here, I’m assuming the 480 response is what triggered your no answer report.

Cause 19 is No answer from user (user alerted)

Thanks, so if i understand, this is my provider and not my FreePBX ?

Assuming the right number is in the INVITE, which you didn’t include, it is your provider that is claiming they are not answering.

NoAnswering - FreePBX Pastebin maybe this pastbin is better ?

Line 212. SIP/2.0 407 Proxy Authentication Required - 4009

Probably need to talk to your provider to get a good understanding of what’s missing/how to configure.

Line 203 shows received=10.201.111.210, presumably the LAN address of the PBX. That’s not possible so it appears that your hardware router/firewall has a SIP ALG enabled. Turn that off and retest. If you still have trouble, paste a new log from /var/log/asterisk/full (the console log lacks timestamps), covering the entire call, as much as 1000 lines.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.