Number Is not in service After 2 calls go through

I can get the First 2 calls to go though but on the 3rd Call everytime NO matter what it gives me that the number youve dialed is not in service
ive seen it where it shows From-zaptel:13 goto From-pstn in new stack so im thinking thats partly the problem ive done extensive google reseach on this paticular issue and read that any/inbound did set meaning i have all DIDs set to go to the Hunt group that ive built to go in order also to change from-pstn To from-zaptel and nope not working also…

THE LOG OF THE ISSUE CALL

Starting simple switch on ‘Zap/4-1’
– Executing [[email protected]:1] NoOp(“Zap/4-1”, “Entering from-zaptel with DID == “) in new stack
– Executing [[email protected]:2] Ringing(“Zap/4-1”, “”) in new stack
– Executing [[email protected]:3] Set(“Zap/4-1”, “DID=s”) in new stack
– Executing [[email protected]:4] NoOp(“Zap/4-1”, “DID is now s”) in new stack
– Executing [[email protected]:5] GotoIf(“Zap/4-1”, “1?zapok:notzap”) in new stack
– Goto (from-zaptel,s,8)
– Executing [[email protected]:8] NoOp(“Zap/4-1”, “Is a Zaptel Channel”) in new stack
– Executing [[email protected]:9] Set(“Zap/4-1”, “CHAN=4-1”) in new stack
– Executing [[email protected]:10] Set(“Zap/4-1”, “CHAN=4”) in new stack
– Executing [[email protected]:11] Macro(“Zap/4-1”, “from-zaptel-4|s|1”) in new stack
– Executing [[email protected]:12] NoOp(“Zap/4-1”, “Returned from Macro from-zaptel-4”) in new stack
– Executing [[email protected]:13] Goto(“Zap/4-1”, “from-pstn|s|1”) in new stack
– Goto (from-pstn,s,1)
– Executing [[email protected]:1] NoOp(“Zap/4-1”, “No DID or CID Match”) in new stack
– Executing [[email protected]:2] Answer(“Zap/4-1”, “”) in new stack
– Executing [[email protected]:3] Wait(“Zap/4-1”, “2”) in new stack
– Executing [[email protected]:4] Playback(“Zap/4-1”, “ss-noservice”) in new stack
– Playing ‘ss-noservice’ (language ‘en’)
and here is the config that i found it in the extensions.conf
I hope im getting somewhere this is just straight from the conf
[from-zaptel]
exten => _X.,1,Set(DID=${EXTEN})
exten => _X.,n,Goto(s,1)
exten => s,1,NoOp(Entering from-zaptel with DID == ${DID})
; Some trunks require a RINGING be sent before an Answer.
exten => s,n,Ringing()
; If ($did == “”) { $did = “s”; }
exten => s,n,Set(DID=${IF($[”${DID}”= “”]?s:${DID})})
exten => s,n,NoOp(DID is now ${DID})
exten => s,n,GotoIf($["${CHANNEL:0:3}"=“Zap”]?zapok:notzap)
exten => s,n(notzap),Goto(from-pstn,${DID},1)
; If there’s no ext-did,s,1, that means there’s not a no did/no cid route. Hangup.
exten => s,n,Macro(hangup)
exten => s,n(zapok),NoOp(Is a Zaptel Channel)
exten => s,n,Set(CHAN=${CHANNEL:4})
exten => s,n,Set(CHAN=${CUT(CHAN,-,1)})
exten => s,n,Macro(from-zaptel-${CHAN},${DID},1)
; If nothing there, then treat it as a DID
exten => s,n,NoOp(Returned from Macro from-zaptel-${CHAN})
exten => s,n,Goto(from-pstn,${DID},1)
exten => fax,1,Goto(ext-fax,in_fax,1)
THIS ONES THE FROM PSTN PART OF THE EXTENSIONS.CONF File
[from-pstn]
include => from-pstn-custom ; create this context in extensions_custom.conf to include customizations
include => ext-did
include => ext-did-catchall ; THIS MUST COME AFTER ext-did
include => from-did-direct ; MODIFICATOIN (PL) for findmefollow if enabled, should be bofore ext-local
exten => fax,1,Goto(ext-fax,in_fax,1)