NTP? Phone time is off - Server is correct

My FreePBX server time is correct - I would like to check where it gets its NTP from… but disregarding that for a moment, the phones are all way off , both date and time. What syncs that up? I see setting on the phones menus but where in FreePBX can I deploy that?

When you type date in cli does it bring you back the correct date & time?

Do you provision your phones or you registered them manually?

If you provision your phones in EPM then there is a setting that sets that for the phone. Otherwise if your provisioning them manually then you need to set that in the GUI/WebGUI on the phone itself.

In CLI the date and time are correct.
I provision the phones using option 66.
The network switch (the DHCP Server) time is correct
The only time related entry I see in FreePBX is not in EPM its in System Admin and its just the time zone.
I’m missing something . . .
OK Correction - I found the time zone under regional, should I change the primary time server to be the FreePBX box instead of the ntp.org server? The phones themselves can’t reach the internet
EDIT: that didn’t work either. Date is in October.

You could set the time server and time zone with options 42 and 2:

42 is the IP address of a time server
2 is the hex time offset - one of the best tables is on SonicWALL’s KB:

You could set the PBX IP as option 42 and go from there…if the phones can’t reach the Internet then yeah ntp.org wouldn’t help much.

Ahh, 42, always the answer to the universe and everything :smile:

But isn’t the EPM supposed to send that to the Sangoma phone? I wouldn’t think I had to set it separately.

I checked the phone and the NTP server IP is there. Perhaps FreexPBX is not an NTP server?

No more ideas? the phones still have the wrong times - what prevents them from getting a time sync from freepbx server?

Okay your template in your EPM for Sangoma Phones should have an area for NTP server. Give it a NTP server that the phones can reach and confirm port 123UDP is open to that server.

It does and I did, but I pointed them at the FreePBX server. What is not clear is if the FreePBX server is an NTP server. Built from the downloaded ISO I don’t know if that was enabled by default. Or even available at all.
…and I’m a complete linux idiot so I dont know how to set one up in Linux if I wanted to.

The phones themselves will have no access to the internet so it has to be gotten from one of this machines other interfaces.

Seen this a couple times

OK, that tells me 2 things
The FreePBX box DOES supply NTP.
and the FreePBX box IS the provisioning server and that’s where they are pointed. So this should work.

These are Sangoma phones so I didnt have to buy an EPM.

You didnt have to buy EPM since you have Sangoma phones, but your phones still pull the EPM config like any other phone.

Hopefully it solves your issue!

I get that part - I only said that in case it was a bug in different phones - Point is that I have it configured as you suggest - but it doesn’t work- phones get config changes from EPM just fine, but NTP doesn’t have any effect. Times on phones are all wrong.

I must have something more serious going wrong here - not only are all the phones displaying the wrong time and date (10-18-2017, 10-13-2017, 2:49 or 10:28) the server time groups are not responding as they should by playing the wrong message for this time.

The server time displayed on the config page is accurate, the NTP setting in the phones is correct. imageimage

What am I missing here. This is the last thing I need to fix before I set this thing up on location and let the people poke at it.

Did you reboot your system after you set the correct time?

I haven’t rebooted the FreePBX box in some time, but the phones have been many times. I will reboot FreePBX, but if that fixes this I will need an explanation.
How can I check if the NTP service (daemon, program, whatever its called here) is running?

rebooted - no change in the phones - still have random times in them.

I’m not linux fluent by a long shot - but typing ntpstat returns “Unable to Talk to NTP Daemon Is it running?” - obviously thats not good.

I’m googling for how to start it but I’m reluctant to deal with the box at this level since I am not competent.

It says very clear in the Wiki.

I have seen it but that pertains to time ZONE. and in any case the server time has always been correct. the phones just dont get it. Rebooting didn’t fix it.