Not hearing sound via agi script

New to FreePBX for some reason my agi script is not playing any sound. The announcements work fine when set up through the online panel.

Here is the AGI script I was using to test

#!/usr/bin/perl

use Asterisk::AGI;

my $AGI = Asterisk::AGI->new();

$AGI->verbose(“AGI script started”);

$AGI->say_number(‘9865’);

$AGI->get_data(‘/var/lib/asterisk/sounds/en/vm-intro’, -1, 10);

$AGI->verbose(“Streamed file”);

$AGI->verbose(“Streamed file”);

$AGI->verbose(“AGI script finished”);

This is the exten part of the “extensions_custom.conf”
[from-internal-custom]

exten => 6001,1,AGI(testing.agi)

I tried with stream file as well

$AGI->stream_file(‘/var/lib/asterisk/sounds/en/vm-intro’);

The reason that I have -1 as time to input was for testing. I tried with different timers.

When I enable AGI debugging it doesn’t throw any errors outside of:

“No registered publish handler for event presence from 201”

The say_number and “get_data” I can’t hear anything… I’ve tried with multiple file formats, multiple files.

Thanks in advance for any help