Not able to update


(Jon Chuchla) #1

I’m trying to update my system and running into issues. I’m currently on version 14.0.16.11. When i go to the system updates page it says:
Current System Update Status:

Idle

Last Online Check Status:Never (Unknown)
Last System Update:Unknown (System updates not run since last reboot)
Updates Available:No updates currently required!

When i click the button to check online, i get a banner error:

Updates did not start. Incron error?
File:/var/www/html/admin/libraries/Builtin/SystemUpdates.php:113

So i SSHed into the box and ran yum upgrade -y and there’s a number of errors at the bottom.

Error: Package: gstreamer-plugins-bad-free-extras-0.10.19-3.el6_5.x86_64 (@base/6)
           Requires: gstreamer-plugins-bad-free = 0.10.19-3.el6_5
           Removing: gstreamer-plugins-bad-free-0.10.19-3.el6_5.x86_64 (@base/6)
               gstreamer-plugins-bad-free = 0.10.19-3.el6_5
           Updated By: gstreamer-plugins-bad-free-0.10.23-23.el7.x86_64 (sng-base)
               gstreamer-plugins-bad-free = 0.10.23-23.el7
 You could try using --skip-broken to work around the problem
** Found 95 pre-existing rpmdb problem(s), 'yum check' output follows:
alsa-lib-1.1.3-3.el7.x86_64 is a duplicate with alsa-lib-1.0.22-3.el6.i686
apr-1.4.8-3.el7.x86_64 is a duplicate with apr-1.3.9-5.el6_2.i686
apr-util-1.3.9-3.el6_0.1.i686 has missing requires of libdb-4.7.so
apr-util-1.5.2-6.el7.x86_64 is a duplicate with apr-util-1.3.9-3.el6_0.1.i686
cairo-1.14.8-2.el7.x86_64 is a duplicate with cairo-1.8.8-6.el6_6.i686
cloog-ppl-0.15.7-1.2.el6.x86_64 has missing requires of libgmp.so.3()(64bit)
cronie-anacron-1.4.4-12.el6.x86_64 has missing requires of cronie = ('0', '1.4.4', '12.el6')
cyrus-sasl-2.1.23-15.el6_6.2.x86_64 has missing requires of libdb-4.7.so()(64bit)
cyrus-sasl-2.1.23-15.el6_6.2.x86_64 has missing requires of libsasl2.so.2()(64bit)
cyrus-sasl-lib-2.1.23-15.el6_6.2.i686 has missing requires of libdb-4.7.so
cyrus-sasl-lib-2.1.26-21.el7.x86_64 is a duplicate with cyrus-sasl-lib-2.1.23-15.el6_6.2.i686
1:dbus-libs-1.6.12-17.el7.x86_64 is a duplicate with 1:dbus-libs-1.2.24-8.el6_6.i686
flite-devel-1.3-14.el6.x86_64 has missing requires of flite = ('0', '1.3', '14.el6')
fontconfig-2.10.95-11.el7.x86_64 is a duplicate with fontconfig-2.8.0-5.el6.i686
freetype-2.4.11-15.el7.x86_64 is a duplicate with freetype-2.3.11-15.el6_6.1.i686
gamin-0.1.10-16.el7.x86_64 is a duplicate with gamin-0.1.10-9.el6.i686
gd-2.0.35-11.el6.x86_64 has missing requires of libpng12.so.0()(64bit)
gd-2.0.35-11.el6.x86_64 has missing requires of libpng12.so.0(PNG12_0)(64bit)
gdb-7.2-75.el6.x86_64 has missing requires of libpython2.6.so.1.0()(64bit)
glib-networking-2.28.6.1-2.2.el6.x86_64 has missing requires of libgnutls.so.26()(64bit)
glib-networking-2.28.6.1-2.2.el6.x86_64 has missing requires of libgnutls.so.26(GNUTLS_1_4)(64bit)
glib-networking-2.28.6.1-2.2.el6.x86_64 has missing requires of libproxy.so.0()(64bit)
glib2-2.50.3-3.el7.x86_64 is a duplicate with glib2-2.28.8-4.el6.i686
gnome-keyring-2.28.2-8.el6_3.x86_64 has missing requires of libtasn1.so.3()(64bit)
gnome-keyring-2.28.2-8.el6_3.x86_64 has missing requires of libtasn1.so.3(LIBTASN1_0_3)(64bit)
gstreamer-plugins-good-0.10.23-1.el6.x86_64 has missing requires of libpng12.so.0()(64bit)
gstreamer-plugins-good-0.10.23-1.el6.x86_64 has missing requires of libpng12.so.0(PNG12_0)(64bit)
gstreamer-python-0.10.16-1.1.el6.x86_64 has missing requires of libpython2.6.so.1.0()(64bit)
gstreamer-python-0.10.16-1.1.el6.x86_64 has missing requires of python(abi) = ('0', '2.6', None)
hal-info-20090716-3.1.el6.noarch has missing requires of hal >= ('0', '0.5.10', None)
1:java-1.8.0-openjdk-demo-1.8.0.51-0.b16.el6_6.x86_64 has missing requires of java-1.8.0-openjdk = ('1', '1.8.0.51', '0.b16.el6_6')
1:java-1.8.0-openjdk-devel-1.8.0.51-0.b16.el6_6.x86_64 has missing requires of java-1.8.0-openjdk = ('1', '1.8.0.51', '0.b16.el6_6')
1:java-1.8.0-openjdk-src-1.8.0.51-0.b16.el6_6.x86_64 has missing requires of java-1.8.0-openjdk = ('1', '1.8.0.51', '0.b16.el6_6')
libX11-1.6.0-2.2.el6.i686 has missing requires of libX11-common = ('0', '1.6.0', '2.2.el6')
libX11-1.6.5-1.el7.x86_64 has installed conflicts libxcb < ('0', '1.11', '4'): libxcb-1.9.1-2.el6.i686
libX11-1.6.5-1.el7.x86_64 is a duplicate with libX11-1.6.0-2.2.el6.i686
libXau-1.0.8-2.1.el7.x86_64 is a duplicate with libXau-1.0.6-4.el6.i686
libXrender-0.9.10-1.el7.x86_64 is a duplicate with libXrender-0.9.8-2.1.el6.i686
libgcrypt-1.5.3-14.el7.x86_64 is a duplicate with libgcrypt-1.4.5-11.el6_4.i686
libgpg-error-1.12-3.el7.x86_64 is a duplicate with libgpg-error-1.7-4.el6.i686
libgudev1-147-2.57.el6.x86_64 has missing requires of libudev >= ('0', '142', None)
libgudev1-147-2.57.el6.x86_64 has missing requires of libudev = ('0', '147', '2.57.el6')
libgudev1-147-2.57.el6.x86_64 has missing requires of libudev.so.0()(64bit)
2:libpng-1.5.13-7.el7_2.x86_64 is a duplicate with 2:libpng-1.2.49-1.el6_2.i686
2:libpng-devel-1.2.49-1.el6_2.x86_64 has missing requires of libpng12.so.0()(64bit)
libpri-devel-1.4.12-13.shmz65.1.4.x86_64 has missing requires of libpri = ('0', '1.4.12', '13.shmz65.1.4')
libproxy-0.4.11-10.el7.x86_64 is a duplicate with libproxy-0.3.0-10.el6.i686
libproxy-bin-0.3.0-10.el6.x86_64 has missing requires of libproxy.so.0()(64bit)
libproxy-python-0.3.0-10.el6.x86_64 has missing requires of python(abi) = ('0', '2.6', None)
librtmp-2.3-1.el6.rf.x86_64 has missing requires of libgnutls.so.26()(64bit)
librtmp-2.3-1.el6.rf.x86_64 has missing requires of libgnutls.so.26(GNUTLS_1_4)(64bit)
libss7-devel-1.0.2-7_centos6.x86_64 has missing requires of libss7 = ('0', '1.0.2', '7_centos6')
libtonezone-devel-2.11.1-1.shmz65.1.47.x86_64 has missing requires of libtonezone = ('0', '2.11.1', '1.shmz65.1.47')
libwat-devel-2.1.0-1.shmz65.1.17.x86_64 has missing requires of libwat = ('0', '2.1.0', '1.shmz65.1.17')
libxcb-1.12-1.el7.x86_64 is a duplicate with libxcb-1.9.1-2.el6.i686
libxcb-devel-1.9.1-2.el6.x86_64 has missing requires of libxcb-sync.so.0()(64bit)
libxml2-2.9.1-6.el7_2.3.x86_64 is a duplicate with libxml2-2.7.6-17.el6_6.1.i686
libxslt-1.1.28-5.el7.x86_64 is a duplicate with libxslt-1.1.26-2.el6_3.1.i686
lua-dbi-0.5-2.el6.x86_64 has missing requires of libmysqlclient.so.16()(64bit)
lua-dbi-0.5-2.el6.x86_64 has missing requires of libmysqlclient.so.16(libmysqlclient_16)(64bit)
openscap-1.0.8-1.0.1.el6.centos.1.x86_64 has missing requires of libpcre.so.0()(64bit)
openscap-1.0.8-1.0.1.el6.centos.1.x86_64 has missing requires of librpm.so.1()(64bit)
openscap-1.0.8-1.0.1.el6.centos.1.x86_64 has missing requires of librpmio.so.1()(64bit)
pcre-devel-7.8-6.el6.x86_64 has missing requires of libpcre.so.0()(64bit)
pcre-devel-7.8-6.el6.x86_64 has missing requires of pcre = ('0', '7.8', '6.el6')
perl-IO-Tty-1.08-4.el6.x86_64 has missing requires of perl(:MODULE_COMPAT_5.10.1)
1:perl-Module-Pluggable-3.90-136.el6_6.1.x86_64 has missing requires of perl = ('4', '5.10.1', '136.el6_6.1')
perl-SGMLSpm-1.03ii-21.el6.noarch has missing requires of perl(:MODULE_COMPAT_5.10.1)
perl-URI-1.40-2.el6.noarch has missing requires of perl(:MODULE_COMPAT_5.10.1)
3:perl-version-0.77-136.el6_6.1.x86_64 has missing requires of perl = ('4', '5.10.1', '136.el6_6.1')
pixman-0.34.0-1.el7.x86_64 is a duplicate with pixman-0.32.4-4.el6.i686
pm-utils-1.2.5-11.el6.x86_64 has missing requires of hal
ppl-0.10.2-11.el6.x86_64 has missing requires of libgmp.so.3()(64bit)
pycairo-1.8.6-2.1.el6.x86_64 has missing requires of python(abi) = ('0', '2.6', None)
pygobject2-2.20.0-5.el6.x86_64 has missing requires of python(abi) = ('0', '2.6', None)
pygtk2-2.16.0-3.el6.x86_64 has missing requires of python(abi) = ('0', '2.6', None)
python-devel-2.6.6-52.el6.x86_64 has missing requires of /usr/bin/python2.6
python-devel-2.6.6-52.el6.x86_64 has missing requires of libpython2.6.so.1.0()(64bit)
python-devel-2.6.6-52.el6.x86_64 has missing requires of python = ('0', '2.6.6', '52.el6')
python-devel-2.6.6-52.el6.x86_64 has missing requires of python(abi) = ('0', '2.6', None)
python-devel-2.6.6-52.el6.x86_64 has missing requires of python-libs(x86-64) = ('0', '2.6.6', '52.el6')
python-ethtool-0.6-5.el6.x86_64 has missing requires of libpython2.6.so.1.0()(64bit)
python-ethtool-0.6-5.el6.x86_64 has missing requires of python(abi) = ('0', '2.6', None)
python-simplejson-2.0.9-3.1.el6.x86_64 has missing requires of libpython2.6.so.1.0()(64bit)
python-simplejson-2.0.9-3.1.el6.x86_64 has missing requires of python(abi) = ('0', '2.6', None)
qt3-3.3.8b-30.el6.x86_64 has missing requires of libpng12.so.0()(64bit)
qt3-3.3.8b-30.el6.x86_64 has missing requires of libpng12.so.0(PNG12_0)(64bit)
radiusclient-ng-devel-0.5.6-5.el6.x86_64 has missing requires of radiusclient-ng = ('0', '0.5.6', '5.el6')
subversion-1.6.11-12.el6_6.x86_64 has missing requires of libdb-4.7.so()(64bit)
subversion-1.6.11-12.el6_6.x86_64 has missing requires of libsasl2.so.2()(64bit)
subversion-1.6.11-12.el6_6.x86_64 has missing requires of perl(Digest::MD5) >= ('0', '2.20', None)
subversion-1.6.11-12.el6_6.x86_64 has missing requires of python(abi) = ('0', '2.6', None)
xz-lzma-compat-4.999.9-0.5.beta.20091007git.el6.x86_64 has missing requires of liblzma.so.0()(64bit)
xz-lzma-compat-4.999.9-0.5.beta.20091007git.el6.x86_64 has missing requires of xz = ('0', '4.999.9', '0.5.beta.20091007git.el6')
zlib-1.2.7-17.el7.x86_64 is a duplicate with zlib-1.2.3-29.el6.i686

Any idea what to do to get things back on track?


(Canada) #2

I have a suggestion which you may or may not like. But it would be relatively painless, because I have done it. Some assumptions:

  1. You do a full backup every night with the back up and restore module.

  2. You backup everything including voicemail and and recordings, literally everything.

  3. Your system even without updates is working and healthy with all modules working how you want them to work.

Fire up a vm, and install freepbx 15. I’d you are going to run all system and module updates after install, beware of userman v 15.0.48. Turn on edge updates for module admin (advanced settings) after updating, check online in module admin and ONLY install userman v15.0.50. Turn off Edge updates for module admin, so that you don’t forget and are not on the bleeding edge for everything.

Freepbx 15 allows the back up and restore module to restore previous versions of freepbx. Take your nightly freepbx 14 backup and restore it on you new freepbx 15 box. Once you are done you have a fully updated and beautiful version of freepbx that is pretty much bleeding edge and fully functional exactly like it was. Run your system updates on a regular basis from the command line, with yum. And run your module updates from module admin on a relatively regular basis. I like to set everything from updates to email only so that I’m notified and no automatic updates are done because I’ve had issues with certain module updates, that had a small bug in them.

Just one more small suggestion. When doing system or module updates, keep a running log in a word or google doc, with the date you did the module or system update, and a screenshot of the modules or system updates applied. The reason I say this is if you notice any areas of freepbx broken you can apply the module or system fix suggested by the bug tracker folks, and then track the date you did the updates and restore from a full nightly that exited Before the broken module did any damage, IE, user man v15.0.48 deleting all contacts out of contact manager—user management group, hence data missing in current backups, but existing in the ones before the applied date of updates. This method is also still applicable if using vm backups. I’m paranoid so I do a full system backup every night that I can also restore from bare metal if need be. And a full backup using the backup and restore module that gets auto offloaded to cloud backup storage.


(Jon Chuchla) #3

I only do weekly backups of this VM because it changes infrequently. I don’t do updates that often. Only every few months. And changes to the configuration don’t happen very often at all. We’re a small 5 person company that doesn’t hire or fire very often, so things just don’t need to change much. We also don’t store voicemails on the pbx server. We push them out via email and delete from the server. So I’ve always regarded less frequent backups to be appropriate for this installation. I’ve always used VM backups for this rather than the internal tools. I’ll have to look into how to use the internal backup and restore tools.
So do you think that it’s safe to backup from this installation to a fresh new one of a newer version? Are there going to be headaches along the way? The FreePBX system seems to be mostly working fine.
Does the restore to the new box include everything, including network settings and license and such? Are there any additional stuff i’ll need to do after restoring?


(Jared Busch) #4

What have you don to this thing that is non-standard?
Because you have a horrible repo mix.
image


(Jon Chuchla) #5

I’m not really sure how it got this way. I’ve always just updated using the normal mechanism either via the web, or occasionally via yum when advised here on the forum. This is the first time I’ve run into problems like this. This server has been running for over 6 years, and has been updated many times.


(Jon Chuchla) #6

ok, I’ve setup a new VM and installed FreePBX version 15.0.17.53. I’ve updated both the OS and all the modules. I had to register it to be able to update the OS via the web. I checked that userman version and it was already at the 50 that was recommended earlier.
I then made a fresh backup of the old pbx instance and did a restore onto the new. It said that it finished with errors. It didn’t really explain much more. I rebooted and when it came back up, I started going thru several of the applications and admin options and it looks like all my users are there, inbound and outbound routes are there, IVR stuff and announcements all seem to be there. So it looks like most of it restored fine. There’s no errors on the dashboard.
It still had the temporary DHCP IP. So i assume I’ll need to set it to match the IP of the old VM. But what else do i need to manually change?


(Jared Busch) #7

Potentially, nothing.


(Canada) #8

@jchuchla, just carefully check that everything is working. Double check Intrusion detection, Double check your SIP driver. and also double check your asterisk sip settings, to make sure everything is correct there. Outside of that, test out as much as you can, but if it looks good and is working, GO with it. And of course static IP it to the old primary as you said, and make sure ALL your phones register with the extensions via SIP. And then you SHOULD be good to go.

PS- FreePBX 15 Is VERY forgiving and accurate in my experience when importing from older versions of FreePBX, they reworked backup and restore, and added the advance recovery module and those have been GOLD for me. If you’re really paranoid about the errors you could make sure you did a FULL backup in backup and restore, on the old primary and then restore again, but if its working and you’re happy I would go with that. Also double check your Contact Manager area (Make sure you can edit a contact) and your User Management are under Admin. Wouldn’t hurt to check that you can edit and add extensions to make sure the DB is looking good. Other than that you should be good to go and you now have a nice fresh cleaned up box, that is good to go for updates! Good job :slight_smile:


(Jon Chuchla) #9

How about licensing. I bought one of those bundled 25 year feature licenses several years ago. How do i check to see if it’s on the new box, or how do i transfer it over?


(Lorne Gaetz) #10

Admin -> Sysadmin -> Activation

https://wiki.freepbx.org/display/FPG/How+to+Move+a+Deployment+ID+to+a+new+PBX


(Jared Busch) #11

Have you purchased updates?


(Jon Chuchla) #12

I’m trying to figure out how to do that. I’m not seeing an option to purchase updates for the bundles i have currently licensed. Do i just purchase the bundle again?

I’m also confused about module versions. I have several modules on this new installation that are showing “newer than online version” in the status column. Is that normal?


(Jared Busch) #13

Because you installed new, which does current modules. Then you activated which looks at what module versions you are actually purchased for, but does not downgrade anything.


(Jared Busch) #14

https://portal.sangoma.com and buy maintenance for them individually.

There is no bundle for yearly maintenance.


(Jon Chuchla) #15

I’m not seeing maintenance in the store, only licenses.


(Lorne Gaetz) #16

https://wiki.freepbx.org/display/FPAS/How+to+Renew+FreePBX+Commercial+Modules+Maintenance


(system) closed #17

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.