Noise on external call pri card

Hi, this is my first system using the latest distro.

i have installed a TE110P PRI card an im just testing out of hours at the moment. when calling into the system the caller hears constant noise/static but it cannot be heard on the handset internally.

Hardware is;
HP Micro server
TE110P pri card
Digium d40 handsets

have tried from mobile/cell and land line and problem is the same. Internal calls are fine unless I call the main number from an internal handset ( out over the pri card and back in) noise can be heard on both

any suggestions?

You will need to set up your hardware to match the clocking presumably slave, framing sf/esf etc. and line coding ami/b8zs to suit your carrier, these if you are in NANP land using T1 tdm. the rest of the world use E1 or J1. Then you will need to set up your ISDN to suit their signalling. Only they can provide you with that information. Only you can follow those directions.

Thanks dicko, it’s my first install so what you say means little at the moment.

If you could tell me where to set the clocking I can find out the correct settings. I’m in the uk using BT

I think they have also :wink: start with “E1 dahdi setup British Telecom”, maybe Lee will step in here.

Top lad. I thing shows same results but with correct spelling and pronunciation ;-p

I’ll have a look. Thanks for the help again

It’s only been 48 years since you guys lost your trousers, and you guys still think you are correct, try searching for disc drives on ebay, hmm, not so many . . .

(Before you have a hissy fit, I am myself an expat, (for good reason, ask Maggie :wink: )

All good jest, no worries.

I bought the system from a reseller who assured me I could ‘just plug it in’ :slight_smile:

Luckily I know that it’s never so simple, excuse my ignorance, it’s my first pbx. File location for changing the config would help muchly

All the dadhdi stuff will be in /etc/dahdi, all the asterisk stuff in /etc/asterisk, remember that dahdi is not part of asterisk, but asterisk needs a properly configured dahdi to use your E1/BT/euro 30 thingy.

Thanks, sent me in right direction I guess. I thought the noise might have been psu bleed over or something

No, it the need for a very precise lock onto the 2Mbit signalling on your TDM E1, followed by the need to isolate the channels into the 32 multiplexed 64kbit channels , and then the decoding (framing and coding) that into both the D (data channels where your calls are set up and torn down) and B (bearer channels, the actual voice channels) and then applying the correct pre/de-emphasis (you use alaw g711) to suit. PSU bleed through will be at 50 HZ it is the same rate that you tv signal and flourescent lamps flicker at, you euro guys should have listened to Tesla and Talbot/Plateau way back then;-)

I here what you’re saying but it zoomed over my head. I’d of thought the goddam reseller would have done this.

I’ll keep learning

hehe you get what you pay for. Who was that reseller, just so others from poor old blighty don’t get similarly stiffed?

Best not in case I get done for deformation of character. It’s 11pm here so I’m going to check settings tomorrow and see how it goes. Ta for help again. Will report back

You need to make sure the clocking is set for net in your DAHDI config file.

You could just have a bad card. The Openvox are good clone cards but you could have a bad one.

Ok, tested a few dahdi settings this morning / Loadzone=UK, Signalling=PRI etc etc.

All gave the same results. i decided to open up the hardware box and check the physical card. Its not a Digium!!! its a Openvox D-110E yet is detected as a Digium TE110P so maybe this is an issue.

The card has a jumper thats set to E1 and also has input and output connectors for a clock.

Not sure were to go next.

the reseller has texted with a IAX trunk and he says its fine. would point to the card. i have mentioned to him the DAHDI settings but he says we shouldnt have to change any of that.

config file is currently;


termtype: te


Global data

loadzone = uk
defaultzone = uk

all i can find regards timing is this;

Sync/Clock Source
0 (internally clocked/providing timing to far end)
1 (primary receiver of timing from far end)
2 (secondary receiver of timing from far end)
3 (tertiary receiver of timing from far end)

but nothing in any of the config files matching or a syntax that matches your setting. could you clarify

do you mean the span setting?