No zaptel channels

Well, it seems like I’ve been posting on here for help way too often, but for some reason, issues keep coming up.

I have two X100P cards in the box, one for incoming and one for outgoing. There were issues with incoming callers not being able to understand what anyone was saying, it was garbled. If I called in on the outgoing line, everything was fine.
Incoming calls to the main line would sometimes be dropped or sometimes pause for a long time before the IVR kicked in.
I was beginning to think it was the card, so I switched the two cards around(as in swapped PCI slots). After that, no calls worked. I switched them back, still nothing.

If I call on the main line now, nothing happens and the call never goes through. If I call into the outgoing line, it rings, but asterisk doesn’t see any activity. When trying to make an outbound call, it would show a chanunavail message.

I tried running genzaptelconf, but it said it could not load zone “us”. I couldn’t get it working, so I updated zaptel, zaptel-modules, and asterisk through yum.
After that, I think I’m in deeper water than before.

When trying to run genzaptelconf now, I get
"line 0: Unable to open master device ‘/dev/zap/ctl’".

I saw some people mentioning udev, so I tried everything that I saw being suggested to other people, like editing the udev permissions and rules. Nada.

Lsmod shows no zaptel modules loaded, and asterisk shows no channels. I can’t modprobe zaptel modules and “service zaptel start” can’t find the modules either.

Can someone point me towards a possible cause? I realize the card may be bad, but need to get the other one working at least.



I think I may have it working, but I’ll double check everything before I say it’s fixed.

After finally getting YUM to install the right kernel source, I compiled the zaptel drivers myself, installed, and configured. I had to modprobe the right module, restart amportal and it worked, but only for one card.

I’m thinking maybe that the other card is broken. I’ve heard bad things about those cards. Both still show up in lspci, but I can’t get the first one visible anywhere else.

If anyone has more ideas about that, let me know, and I’ll post more as I figure more out…

So that you know x100 cards are known to have about the same quality as a pair of Tin can’s with string between them during a rain storm. x100 cards are glorified modems that sort of work. For every one that does with there are nine that don’t.

You have provided no information about versions of anything, OS setup, hand built or Distro, etc. So we don’t know what versions of asterisk you are running to know if you have one of the newer versions that now default to dahdi interfaces or not.

I do realize that the x100 cards are crap, but unfortunately it’s out of my hands :frowning:
I tried to convince my boss to get better cards a few months back, but he didn’t go for that. Maybe after both of these cards die, he’ll change his mind.

The box is Trixbox CE 2.4.2.
Asterisk 1.4.22-3

I didn’t install the dahdi drivers yet, just because it “should” have been working with what it had, and I wanted to fix that before upgrading and complicating it further.

I’m guessing it’s just the card that’s bad, because I was able to get the other one working again. The “bad” one doesn’t show up, but I don’t know if I’m maybe missing some basic zaptel/asterisk/linux commands that would help troubleshoot it.
Sorry for the previous lack of info. But maybe you can give me some pointers.

I hate not being the one who set up the box, but has to fix the mess that if has become :slight_smile: