No Voicemail, Indefinite ring?

Right now, it seems that any extension without voicemail still times out and gives an “an error has occurred” type message.

Is there any way to make the call to an extension without voicemail ring forever?

There are a couple different things happening here:

RexPoke: you are making a call to an extension with no voicemail box and the phone is not available (That’s what your 502 response is about). Since there is no where to go (no voicemail) and no phone it can ring it provides a congestion tone - that seems like a reasonable way to handle such a call.

rward0:
in your case, you are hitting an extension that appears to have voicemail but the call to voicemail does not work so it is trapped as an error condition. You said you did not enable voicemail in “Tools” - I think you mean you did not enable the voicemail module. Unfortunately, you need to enable the voicemail module and we will be finding a way to force it to be installed. (It should never have been pulled out to a separate module from core - but that is a whole different story …). Things just don’t work if it is not installed. You can function with no voicemail boxes fine if that is what you want but install the module.

Bump to see if anyone else might have input on this :slight_smile:

[quote=“RexPoke”]Right now, it seems that any extension without voicemail still times out and gives an “an error has occurred” type message.

Is there any way to make the call to an extension without voicemail ring forever?[/quote]

I can confirm the same for FreePBX 2.2.2 and I’ve just finished upgrading to 2.2.3 and still get:

-- Executing [[email protected]:2] Set("IAX2/202-4", "VMGAIN=") in new stack
-- Executing [[email protected]:3] GotoIf("IAX2/202-4", "1?s-CHANUNAVAIL|1") in new stack
-- Goto (macro-vm,s-CHANUNAVAIL,1)
-- Executing [[email protected]:1] Macro("IAX2/202-4", "get-vmcontext|110") in new stack
-- Executing [[email protected]:1] Set("IAX2/202-4", "VMCONTEXT=") in new stack
-- Executing [[email protected]:2] GotoIf("IAX2/202-4", "1?200:300") in new stack
-- Goto (macro-get-vmcontext,s,200)
-- Executing [[email protected]:200] Set("IAX2/202-4", "VMCONTEXT=default") in new stack
-- Executing [[email protected]:2] VoiceMail("IAX2/202-4", "[email protected]|u") in new stack
-- Executing [[email protected]:3] Goto("IAX2/202-4", "exit-FAILED|1") in new stack
-- Goto (macro-vm,exit-FAILED,1)
-- Executing [[email protected]:1] Playback("IAX2/202-4", "im-sorry&an-error-has-occured") in new stack
-- <IAX2/202-4> Playing 'im-sorry' (language 'en')
-- <IAX2/202-4> Playing 'an-error-has-occured' (language 'en')
-- Executing [[email protected]:2] Hangup("IAX2/202-4", "") in new stack

Situation:
Loaded asterisk, FreePBX, etc. Did NOT enable Voicemail in “Tools”.
Created a couple of Extensions.
Dialed an extension that was not connected and I get the error above.

even with Voicemail enabled in Tools and Disabled on the Extension I still get the same thing, no ringing - just direct to “error”.

Is there a “global error catchall” where you can have a “If error -> send call to extension xxx” where xxx could be a receptionist, ring group, etc… instead of having to define a forward per person…

[quote=“p_lindheimer”]what version are you using? extensions that have no voicemail should not have the timeout applied:

[code:1]
[macro-exten-vm]
exten => s,1,Macro(user-callerid)

exten => s,n,Set(RT=${IF($[$["${VMBOX}"!=“novm”] | $[“foo${CFUEXT}”!=“foo”]]?${RINGTIMER}:"")})
exten => s,n,Macro(record-enable,${EXTTOCALL},IN)

exten => s,n,Macro(dial,${RT},${DIAL_OPTIONS},${EXTTOCALL})
[/code:1]
note the check, if ‘novm’ then RT is set to “” which should make it ring forever.[/quote]
The other system is down right now and I have to get it rebooted, but I just tested on a fresh TB 2.2 install with freePBX 2.2.1:

-- Executing Dial("SIP/7788-0a117578", "SIP/7722||") in new stack
-- Called 7722
-- SIP/7722-0a13d7a8 is ringing
-- Got SIP response 502 "Bad Gateway" back from 10.10.10.99

== Everyone is busy/congested at this time (1:0/0/1)
– Executing GosubIf(“SIP/7788-0a117578”, “0?docfu|1”) in new stack
– Executing GosubIf(“SIP/7788-0a117578”, “0?docfb|1”) in new stack
– Executing NoOp(“SIP/7788-0a117578”, “Voicemail is novm”) in new stack
– Executing GotoIf(“SIP/7788-0a117578”, “1?s-CHANUNAVAIL|1”) in new stack
– Goto (macro-exten-vm,s-CHANUNAVAIL,1)
– Executing PlayTones(“SIP/7788-0a117578”, “congestion”) in new stack
– Executing Congestion(“SIP/7788-0a117578”, “10”) in new stack
== Spawn extension (macro-exten-vm, s-CHANUNAVAIL, 2) exited non-zero on ‘SIP/7788-0a117578’ in macro ‘exten-vm’
== Spawn extension (macro-exten-vm, s-CHANUNAVAIL, 2) exited non-zero on ‘SIP/7788-0a117578’

The result is a little different - maybe because this test was an extension to extension call instead of an DID inbound to extension? I think the SIP response 502 might be a phone / network issue?

I’ll try to get some more information…

what version are you using? extensions that have no voicemail should not have the timeout applied:

[code:1]
[macro-exten-vm]
exten => s,1,Macro(user-callerid)

exten => s,n,Set(RT=${IF($[$["${VMBOX}"!=“novm”] | $[“foo${CFUEXT}”!=“foo”]]?${RINGTIMER}:"")})
exten => s,n,Macro(record-enable,${EXTTOCALL},IN)

exten => s,n,Macro(dial,${RT},${DIAL_OPTIONS},${EXTTOCALL})
[/code:1]
note the check, if ‘novm’ then RT is set to “” which should make it ring forever.