No /var/log/asterisk/full (solved)


Freshly installed the latest (FreePBX 32Bit Beta Distro) release and all is working well except one thing, there are no log files! Well, al least not the /var/log/asterisk/full.

When I got to Reports -> Asterisk Logfiles from the topmenu it also is referring to that file, but it’s not there. Any help would be great because I’m trying to get the Dialectic plugin working like on my previous Elastix box, but without the logs it’s damn near impossible to find out why things aren’t working!

Does the file exist and is it empty or does the file not exist?

It doesn’t exist at all. I made one using SSH with Touch Full and did a chown asterisk:asterisk but it stayed empty.

Did you restart after creating the file?

You don’t need to restart the whole machine or even Asterisk. Check out the logging commands in the Asterisk CLI. You can reload logger their.

The distro should setup log rotate to rotate the logs. After the logs are rotated log rotate creates new empty files and issues a command to Asterisk to restart logging.

Check out /etc/logrotate.d/asterisk which is the log rotate config file that rotates the Asterisk logs.

The command to cause Asterisk to reload the logs is

/usr/sbin/asterisk -rx ‘logger reload’

Thanks for the suggestions, I finally got it working, I checked the file logrote.d and it was empty? Luckily I had a virtual machine with a test installation of the latest (non-beta release) and copied the contents from that file into the logrotate.d. After that, the logs worked again!