No txgain/rxgain option

Hi guys, I’m new to this, i have a tdm card with 2fxo/2fxs, i can make calls and receive, but have a question:

why dont i see the txgain/rxgain options in the extensions parameters? am i doing someting wrong?

also my chan_dahdi.config files only has the following:


; Copied from DAHDI Module of FreePBX

[general]

#include chan_dahdi_general.conf

[channels]

; include dahdi groups defined by DAHDI module of FreePBX
#include chan_dahdi_groups.conf

; include dahdi extensions defined in FreePBX
#include chan_dahdi_additional.conf


that’s it… no general settings like all the examples i see here in the forums…

HELP?

Fernando

Hello,
Chan_dahdi.conf is the first file read by asterisk. You will need to also look at the files mentioned in the lines that start with “#include” for additional settings that will be applied to your configuration.

But more importantly, to answer your question, you can just add the lines ‘txgain=0.0’ and ‘rxgain=0.0’ to where your hardware channels are being configured for use or, if you want it to apply to all channels, then just add it under the [general] section.

Remember to reload your asterisk modules for the change to take effect.

Xorcom Tech

Hi xorco.tech, thanks for taking the time to answer I appreciate it, i did take a look at the files that are mentioned in the file after the #include, the first one is chan_dahdi_general.conf but that appears empty except for the following:


;--------------------------------------------------------------------------------;
; Do NOT edit this file as it is auto-generated by FreePBX. All modifications to ;
; this file must be done via the web gui. There are alternative files to make ;
; custom modifications, details at: http://freepbx.org/configuration_files ;
;--------------------------------------------------------------------------------;
;

~
~


Then i took a look at “chan_dahdi_groups.conf” and it produced the following:
;--------------------------------------------------------------------------------;
; Do NOT edit this file as it is auto-generated by FreePBX. All modifications to ;
; this file must be done via the web gui. There are alternative files to make ;
; custom modifications, details at: http://freepbx.org/configuration_files ;
;--------------------------------------------------------------------------------;
;

signalling=fxs_ks
context=from-zaptel
channel=>1

signalling=fxs_ks
context=
channel=>2

signalling=fxo_ks
context=from-analog
channel=>3

signalling=fxo_ks
context=from-analog
channel=>4


And the last one mentioned in the file is “chan_dahdi_additional.conf” and it has the following:


;--------------------------------------------------------------------------------;
; Do NOT edit this file as it is auto-generated by FreePBX. All modifications to ;
; this file must be done via the web gui. There are alternative files to make ;
; custom modifications, details at: http://freepbx.org/configuration_files ;
;--------------------------------------------------------------------------------;
;

;;;;;;[2003]
signalling=fxo_ks
pickupgroup=
[email protected]
immediate=no
echotraining=800
echocancelwhenbridged=yes
echocancel=yes
context=from-internal
callprogress=no
callgroup=
callerid=device <2003>
busydetect=no
busycount=7
accountcode=
channel=>3

;;;;;;[2004]
signalling=fxo_ks
pickupgroup=
[email protected]
immediate=no
echotraining=800
echocancelwhenbridged=yes
echocancel=yes
context=from-internal
callprogress=no
callgroup=
callerid=device <2004>
busydetect=no
busycount=7
accountcode=
channel=>4


I understand that this is only for the fxs ports included in the tdm card, but where do i see the same info but regarding the sip extensions?

and where in the file do i insert the txgain/rxgain options to tweak the quality?

also how come it says here that the echocancel is set to yes but if i do a “dahdi show channel 3” or whatever channel, i get the line “Echo Cancellation: 128 taps currently OFF”
???

i know my questions are very newbie, but i appreciate the help…

FERLUNA

To Answer your questions:

You can follow the path of your sip extensions configuration by starting at sip.conf and following the #include files there.

You can insert the tx/rxgains into any custom file that is specified, or create your own custom file. Since all of the ones you show above are for freepbx use only, and can not be edited by hand, I would look at what can be added through the module for additional files that you may #include. (Personally, I do not use the Dahdi Module for freepbx because i have seen it cause problems. Maybe when they get ALL the bugs worked out of it, I will try it again.)

The reason it says “128 taps currently OFF” is because your device is set to use 128 taps, however, it is not currently using echo cancellation at the moment because the device is not “offhook”.

Xorcom Tech