No sound with Playback()

I have an Asterisk server. When some one calls to the server, it just plays back a voice file, like this:

Playback(/usr/en_welcome_notice)

It had worked well for a long time before last night.

I did not do any changes in the Asterisk server and dialplan files, but last night when I called to the server, I heard no sound.

This is the log I extracted from /var/log/asterisk/full for the call:

[2014-05-28 13:47:57] VERBOSE[15808][C-0000037c] sig_analog.c: -- Starting simple switch on 'DAHDI/1-1' [2014-05-28 13:47:58] VERBOSE[15808][C-0000037c] pbx.c: -- Executing [[email protected]:1] Goto("DAHDI/1-1", "ivr-appkorea,82522225333,1") in new stack [2014-05-28 13:47:58] VERBOSE[15808][C-0000037c] pbx.c: -- Goto (ivr-appkorea,82522225333,1) [2014-05-28 13:47:58] VERBOSE[15808][C-0000037c] pbx.c: -- Executing [[email protected]:1] NoOp("DAHDI/1-1", "01065057528") in new stack [2014-05-28 13:47:58] VERBOSE[15808][C-0000037c] pbx.c: -- Executing [[email protected]:2] Answer("DAHDI/1-1", "") in new stack [2014-05-28 13:48:04] VERBOSE[15808][C-0000037c] pbx.c: -- Executing [[email protected]:3] Playback("DAHDI/1-1", "/usr/en_welcome_notice") in new stack [2014-05-28 13:40:56] DEBUG[15801][C-00000379] format_wav.c: Skipping unknown block 'LIST' [2014-05-28 13:48:04] VERBOSE[15808][C-0000037c] file.c: -- Playing 'en_welcome_notice.slin' (language 'en') [2014-05-28 13:48:05] VERBOSE[15808][C-0000037c] pbx.c: -- Executing [[email protected]:4] Hangup("DAHDI/1-1", "") in new stack [2014-05-28 13:48:05] VERBOSE[15808][C-0000037c] pbx.c: == Spawn extension (ivr-appkorea, s, 4) exited non-zero on 'DAHDI/1-1' [2014-05-28 13:48:05] VERBOSE[15808][C-0000037c] sig_analog.c: -- Hanging up on 'DAHDI/1-1' [2014-05-28 13:48:05] VERBOSE[15808][C-0000037c] chan_dahdi.c: -- Hungup 'DAHDI/1-1' After trying to find on the internet but found nothing, I tried to restart the server then it worked correctly.

Anyone who knows about this, please give me some explanations!

Please tell us about your system, versions, how it was installed. What version of FreePBX?

If you downloaded the file and tried to play it back on your desktop will it play?

I kinda suspect the file is corrupt.

I installed AsteriskNOW (all in one iso file AsteriskNOW-3.0.0-x86_64-DVD.iso).
I usually update the system by using ‘Module Admin’ function in my FreePBX page.

Here is some information I got from my Asterisk server:

  • Asterisk version: 11.3.0
  • FreePBX version: 2.11.0.37 (I saw in the footer of my FreePBX page)

Actually I downloaded the file then played it on my desktop, it was played correctly. I also tried to replace

Playback(/usr/en_welcome_notice)

by

Playback(goodbye) ;goodbye is a built-in file in Asterisk system

then I got the same result.

If you made that same call but internally via an extension for example, does it have the same issue?

I did not check this. Sorry.