No sound on SIP call. No NAT on server

OK… I’m a bit of a noob at all this but I’ll describe what I have setup first…

Setup a Ubunto 14.04 server on MS Azure Cloud platform.

Used the following guide to install Asterisk 11.7 and Freepbx 12.0.3…

In Freepbx Sip settings I reduced the number of RTP ports (10000-10006), I also set NAT to ‘no’ and entered the static IP(VIP) of the Azure server.

On Azure I added endpoints for UDP 10000-10006, TCP 5269, UDP 5060.

I have 2 Generic SIP extensions programmed in through Freepbx and 2 mobile handsets each running CSipSimple Sip Client. I am not using inbound/outbound trunks at this stage…I am just trying to get 2 handsets to ‘talk’ to each other using the Asterisk/Freepbx platform.

When I run the SIP client on both handsets they register successfully. I can call from one handset to the other and ‘answer’ the call on the receiving handset but I can’t get sound on either handset.

Everything I have read so far suggests that 99% of these ‘sound’ issues are related to NAT. I’m not using NAT! I have tried with NAT on and off, have also tried using DynamicIP instead of StaticIP, rebooting the server and SIP clients after each change but nothing seems to make a difference.

There must be something simple that I’m missing but, as a noob I’m really not sure where to look next.

All help greatly appreciated.


PS - I’m also new to Ubuntu so if I need to do something on the CLI please be quite specific otherwise I’ll get completely lost! Thanks. :slight_smile:

ok… installed a different SIP client on the handsets and can see that both handsets are sending packets but neither are receiving anything!!!

Not sure if that helps at all?

In the Extensions module, where you have defined the extensions that are connecting remotely, change NAT to Yes. Just to be clear, I’m talking about the NAT settings in the EXTENSIONS module and not in the Asterisk SIP Settings Module…

Your extension are probably behind some kind of NAT…