No Sound on RingGroup/Voicemail only on external Calls (via SIP-Trunk)


(Egfy123) #1

Hello,

i have a strange Problem.
My basic Setup is: SIP-Trunk(FritzBox) -> InboundRule -> RingGroup -> VMBlasting
For internal Calls it works perfectly as expected. But for an external Call via the SIP-Trunk, there is no sound by the RingGroup/VoiceMail Announcements. If the Call was answered, everything is OK. But the Beep, recorded or Numer Announcements are muted.
If I change the setup as following; SIP-Trunk(FritzBox) -> InboundRule -> Extension -> Voicemail everything worked fine, also with the VM. All Announcements are loud and clear :slight_smile: Unfortunately this is not my favorite Setup…

The Logs for the three Cases are by Pastebin: h t t p s://pastebin.com/9xHmiqc0

I use the following Software-Versions on an clean (Proxmox) Installation:
PBX Version:
15.0.17.43

PBX Distro:
12.7.8-2107-3.sng7

Asterisk Version:
16.17.0

Can anyone help by resolving this issue?! I spend two Days by solveing this issue an i have no more Ideas :frowning:

Thx


#2

Try enabling fax detection for a test. I had the same issue and this fixed it. I think it has something to do with the system “answering” the line before ringing the phones.


(Egfy123) #3

You are GENIUS - thats solved my Problem :slight_smile: I`m sooo happy - thank you :slight_smile:


(Itzik) #4

Is that’s the case, then you can simply force the channel to answer on the inbound route. Fax detection may delay the incoming call, depending on your routing logic.


#5

Yeah you’re right ! I forgot about this option.


(system) closed #6

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.