No Sound on Internal Calls and Dropping and Trunk Calls With Sound that are dropping

Hi, I have two problems,

The first is that internal calls have no sound and subsequently drop.
The second is that calls coming in from the trunk have sound both ways but subsequently drop within a minute or two.

I have pastebinned the sip debug but from what I have seen and my little understanding of it, firstly my introduction with further detail of my tests is at the top, and it seems sensible to approach the debug from the bottom as I suspect I’ve added in much more than I need to. I’m just not sure what to cut out.



You have contrived to make your internal calls external

<--- Transmitting (NAT) to --->
SIP/2.0 200 OK
Via: SIP/2.0/UDP;branch=z9hG4bK-d8754z-0f484e4e61660905-1---d8754z-;received=;rport=49962
From: "048664"<sip:[email protected];transport=UDP>;tag=06576d27
To: "048664"<sip:[email protected];transport=UDP>;tag=as314e1b87
Server: FPBX-2.11.0(11.6.0)
Supported: replaces, timer
Expires: 60
Contact: <sip:[email protected]:49962;rinstance=00f732eec9d3cc8d;transport=UDP>;expires=60
Date: Sat, 11 Apr 2015 14:18:38 GMT
Content-Length: 0

Notice and both ip’s within


I would check your NAT settings as at .247 should not be your PBX’s address on the wireless network

1 Like

Thanks for this, would this just be NAT inside the Freepbx GUI? Also, I am attempting to connect to my server away from home - does this make any difference (that I am not attempting to make and receive internal calls in the same wireless network?

Secondly, do you believe this issue is effecting both calls coming in off the external trunk (unlike the internal calls issue I have both way audio but the calls are dropping) and the internal issue at the same time?

Please could you give me a little more guidance as to how to attempt to resolve this issue? Would it be useful if I screenshot my freepbx GUI NAT settings?



Start with some time in the wiki particularly

1 Like

Hi Dicko, Thanks for your message.

I’ve resolved the issue until the system decides to break again (it does because it’s running the God-awful old AsteriskNOW package with FreePBX bundled in - as soon as you update in FreePBX AsteriskNOW ends up corrupted in some fashion).

The solution, for now, appears to be setting the Network external IP as Public rather than Static (even though it is Static) and as the network/PBX is behind my router at home (I am accessing it at my other home 100 miles away), I have left NAT set to yes across the whole system (these settings relate to the FreePBX GUI).

It really comes to something when you have to trick the system to get it working properly. Gah.