FreePBX | Register | Issues | Wiki | Portal | Support

No Sound on FreePBX (running on VMFusion)


(Russell450) #1

Hi, I’m new to FreePBX.

I set it up as a virtual machine and I’m trying to use XLite to make calls. I setup an extension and correctly inputted the info on XLite and the registration successfully completed.

Then I made a test call on XLite and it would call the phone, but there’s no sound. I believe it’s a networking issue, but I don’t know what to do.


(Itzik) #2

Is the Softphone and the PBX on the same subnet?
Under SIP Settings did you add the local network?


#3

As @PitzKey says. Also confirm that external IP is correct. Restart (not just reload) after network config changes.

Be sure that you are using bridged networking https://kb.vmware.com/s/article/1022264 .

In X-Lite, Topology -> Firewall Traversal, set Use local IP address.

If X-Lite is not on same LAN as the PBX, describe your network setup.

Does an internal call, e.g. to *43 (echo test) work? If not, we’ll debug that first. If yes, post details of trunking provider, pjsip or chan_sip, audio in either direction, etc.


(Russell450) #4

I haven’t added the local network. How do I do that?

Bridged networking is being used for the virtual machine.

Internal calls work just fine. Audio is working in both directions in internal calls. However, when dialing out, audio is absent in both directions.

I’m using SIPStation and I’ve used pjsip and chan_sip (neither would work), but I’m currently using pjsip.


(Russell450) #5

I just tried adding the local network under Asterisk SIP Settings with Detect Network Settings.

Then I applied the settings and restarted the virtual machine and the call still had no audio.


#6

That seems redundant. Did you mean “Audio is working in both directions in incoming calls”? If so, that points to a problem with your network (between the host and the internet). If not, what does happen on incoming calls?

Who is your ISP? Modem make/model? Configured as router? Separate router or firewall? Any special settings (port forwards, firewall rules, etc.) in network devices? Any other devices in the path (other than dumb switches)?


(Russell450) #7

No I mean the audio works perfectly when dialing internal extensions. But when dialing out, there is no audio whatsoever, whether they are incoming or outgoing calls.


#8

OK, so please tell me about your network.


#9

Does the Asterisk log show any errors on a failed call, other than disconnecting for lack of RTP after ~30 seconds?

Possibly, this is a codec issue. Are you using anything other than ulaw (a.k.a. G.711U or PCMU) in the path?

While there are many causes of no incoming audio, mostly related to NAT and firewall issues, no outbound audio is unusual. Do you have a firewall that blocks any outbound traffic? Or are you aware of any SIP ALG or other SPI in the path?


(Russell450) #10

I have a modem connected to a wireless router. I could try disabling the firewall on the router and see if that resolves anything.


#11

Is ‘wireless’ just a general comment or is your Mac host actually connected via Wi-Fi? If the latter, can you try connecting with an Ethernet cable?

Please post make/model of modem and router.


(Russell450) #12

I actually can’t connect the Mac via ethernet because I don’t have the USB-C to ethernet dongle (yes, the dongle life is a real struggle). It’s a Linksys EA8300. Edit: The modem is an Arris Touchstone TG1672


#13

Is the TG1672 in bridge mode? (If the EA8300 does not have a public IP address on its WAN interface, it’s not.)

If not in bridge mode, the modem has its own Wi-Fi AP. Can you try connecting your Mac to that? Or try setting bridge mode (assuming that you are not using Wi-Fi or any Ethernet ports other than port 1 where the 8300 is connected).

In the 8300, disable SIP ALG. If that doesn’t help, try forwarding UDP ports 10000-20000 to the private (LAN) IP address of the PBX.


(Russell450) #14

I think bridge mode is on because I’m trying to connect to the modem AP and it’s not working, and I’m using the correct password.

On the 8300, SIP ALG was already disabled and I’ve forwarded the ports. After restarting the server, the calls still have no audio.


#15

Log into the 8300 and look at its WAN address. If it begins with 192.168, 10, or 172.16-31, that is a private address and your modem is not in bridge mode. If that is the case, try logging into the modem; see https://www.router-reset.com/reset-manuals/Arris/TG1672G#factory-default-settings , either to fix the Wi-Fi or to set up bridge mode.

If the modem is bridged, try running Wireshark on the Mac host and capturing a failing call. We can then see whether RTP is being sent out, whether it’s properly formatted and going to the correct IP and port, and whether it actually contains voice. If all those are true, the router is likely at fault.

Or, do you have something else you can connect the Mac to for testing, e.g. your smartphone acting as mobile hotspot, your neighbor’s Wi-Fi, a VPN (commercial, or to your workplace or school), etc?


(system) closed #16

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.