No sound for some incoming calls

Dear Community,

This is a fresh (and first, so please be indulgent :wink:) installation of freebpx on a virtual server. It’s the default installation and I haven’t installed any “fancy” modules yet. The version of FreePBX is 5.211.65.

All outgoing calls work great. Randomly, we will not hear our correspondent. On their side, they hear the phone ringing, but they don’t know somebody has picked up the call. On our side, we hear absolutely nothing.

I’m new to this but I did my homework first. I opened all the recommended ports (http://www.freepbx.org/support/documentation/howtos/howto-resolving-audio-problems) but some of the instructions on that link are too advanced for me. The fact that the other person doesn’t know that we took the call indicates (in my opinion) that it’s not really an audio problem (or codec), but something else.

I did have a look at the logs, but nothing really surprise me (except for the dozen of lines per second :)).

Any pointers ? What could I test ?

Thank you for your help

Are you allowing RTP through your firewall?

I would assume so, but I don’t see any particular settings on my Zywall USG 20.

My Server has address 192.168.3.6 and my SIP phones are on address 192.168.4.x.

Any suggestions ?

If you use the Registration String in your trunk settings, you shouldn’t need to open any ports on your router for FreePBX to work. I want to emphasize this: NO PORTS NEED TO BE OPENED for most applications. If you find yourself having to forward RTP ports or SIP ports, you have a bad router.

Check the Asterisk SIP Settings Module and make sure you have the NAT, External IP, and internal IP addresses set correctly.

Make sure you have directmedia=no in the PEER details of your trunk.

If your extensions are on the same network as your FREEPBX, make sure NAT=NO is set in the Extension Module settings for each extension. If your extensions are on a different network and behind a NAT, change that to NAT=Yes.

Check your router and make sure that SIP ALG and any other SIP helper features are turned off.

If the problems continue, try a different router and/or a different service provider.

I am seeing the exact same thing…Was there a fix to this?

In our case, an upgrade of Asterisk to version 11 fixed the issue.