No Sound at all after YUM Update of Asterisk11-core and addons


FreePBX Distro BETA-3.211.63-5 x86

I made an incredibly phenomenal boo boo of allowing Yum to update Asterisk core and since then have zero audio between extensions or internal to external or external to internal.

This happens about 5 minutes after a fresh boot and is not remedied by amportal restart.

Only a reboot temporarily restores audio for 5 minutes.

I have tried deleting and recreating the extensions, trunks, and removing all codecs from the sip configuration except g711u.

There is no ringback sound on the calling extension while waiting for an answer either.

This is the yum.log entries referring to what it updated.

Mar 08 11:46:09 Installed: libsrtp-1.4.4-4.20101004cvs.el6.i686
Mar 08 11:46:10 Updated: asterisk11-flite-debuginfo-11.2.1-46.i686
Mar 08 11:46:10 Updated: yum-kmod-1.1.16-21.16.21.el6.noarch
Mar 08 11:46:11 Updated: asterisk11-core-11.2.1-46_centos6.i686
Mar 08 11:46:11 Updated: asterisk11-addons-core-11.2.1-46_centos6.i686
Mar 08 11:46:11 Updated: asterisk11-addons-mysql-11.2.1-46_centos6.i686
Mar 08 11:46:12 Updated: asterisk11-addons-bluetooth-11.2.1-46_centos6.i686
Mar 08 11:46:12 Updated: asterisk11-addons-ooh323-11.2.1-46_centos6.i686
Mar 08 11:46:12 Updated: asterisk11-addons-11.2.1-46_centos6.i686
Mar 08 11:46:12 Updated: asterisk11-doc-11.2.1-46_centos6.i686
Mar 08 11:46:12 Updated: asterisk11-dahdi-11.2.1-46_centos6.i686
Mar 08 11:46:12 Updated: asterisk11-curl-11.2.1-46_centos6.i686
Mar 08 11:46:12 Updated: asterisk11-odbc-11.2.1-46_centos6.i686
Mar 08 11:46:12 Updated: apr-1.3.9-5.el6_2.i686

As it turns out, somehow, the rtp.conf file was missing the sections for rtpstart and rtpend.

FreePBX updates the rtp_additional.conf but there was no #include statement in rtp.conf.

I tried to put the #include rtp_additional.conf statement in and it still didnt work so putting the contents of the rtp_additional.conf file in the rtp.conf file solved my audio problem.

You probable had a warning that said that the rtp.conf existed and it could not make the symlink. The newest core (in 2.11) creates a symlink to the file…but if one exists it will give you a warning. Usually deleting the rtp.conf and apply changes in gui will recreate the correct link

RTP, we don’t need know stinkin’ RTP {{{g}}}

The yum update process didnt give me a warning, it simply renamed my old rtp.conf to rtp.conf.old and added #include rtp_custom.conf which was a new empty file.

My old rtp_additional.conf was still there.

Ill try deleting the file and applying and see if it symlinks like its supposed to.

It worked, deleting the rtp.conf file and applying changes produced a new one with both rtp_additional and rtp_custom

; Copyright © 2012 Astrogen LLC (USA)

#include rtp_additional.conf
#include rtp_custom.conf

On a fresh install of 2.11 beta, everything was right in the world with rtp.conf.

However, just like the YUM update process on my other install, using the asterisk-version-switch script which uses YUM replaces the rtp.conf file again which hoses the audio.

So, the procedure needs to be, if you run a yum update, remove the rtp.conf file and if you use the asterisk-version-switch script, remove the rtp.conf file.

I wonder now that the RTP settings have been moved to the SIP property page of the settings, if the module can be a little more aggressive in nuking the orphaned rtp.conf - we use non-standard ports on all our installs so we are in the habit of checking the file, but it would be handy if we only had to check one place - the SIP settings.