No RTP for internal calls

I’m very new to Freepbx but I’ve managed to get things set up for testing internally, and I can make and receive calls fine. However I am getting no RTP traffic.

Wireshark tells me the RTP was going to an external address (I have everything on my internal lan at the moment just for testing). I noticed the address was Aha I thought. I hadnt set my local network, and external IP address in my SIP settings. So I did this, but it still did the same thing. So I set my external IP address in the SIP setting for chan_pjsip and also I set Static IP in the SIP Legacy Settings.

Now I dont seem to gat ANY rtp, not even to the wrong address. Can someone point me in the right direction here?


If the fields are set correctly in Asterisk SIP Settings, then try restarting asterisk

fwconsole restart


And as if by magic, the shop keeper appeared!!

In other words, it works now. Thank you very much for the suggestion.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.