No ringing to external caller with queue

We have a new install of FreePBX (AsteriskNow .iso install). Our dialplan is pretty straight forward. When calls come in, they go to a queue for 10 seconds that rings everyone and then to an IVR. The logic works great and, when you call from internal, it works great. The problem though is that when an external caller calls in, there is no ‘ringing’ sound while the extensions are ringing, just dead air. In the Queue definition, I have Ringing Instead of MoH: checked and have even set MoH to ‘none’ (have actually tried inherit, default and none, but it doesn’t seem to make a difference). I’ve looked at the extensions_additional.conf file and can see that the queue is being called correctly (e.g., the ‘r’ option is being specified) and it does work when testing internally, just not externally. I will be happy to provide any additional details to interested parties, and appreciate any assistance that you can provide.

Also, because I believe the two are related, we have no Music On Hold on the box either. We had originally uploaded several MP3 files from our old (Asterisk v1.4.x) box, but that didn’t work. We then tried .wav files, which didn’t work either, but that’s a much smaller issue than the ringing at this point.

please provide complete dtails on the trunk type and setting for what you are using. If you are using SIP and crossing a firewall please include the sip_nat.conf and/or the sip_general_custom.conf file (which ever holds your nat settings) settings.

Wow, talk about a quick response!! The trunk is a SIP trunk and it is crossing a SonicWall TZ-190 firewall. We have nat=yes for the trunk, and the sip_nat.conf is empty.

One thing that may (or may not be) important is that we recorded a 1 second .wav file and set it up as an announcement and calls go to it before going to the queue. A call comes in -> Time Condition -> Business Hours -> 1 second silence -> Queue, and we get ringing, music on hold, etc. It’s admittedly a hack but it seems to work and, perhaps that gives some hint as to what the actual problem is. Thank you for your prompt response, it certainly caught me off guard. I’ll be certain to check back on a much more frequent basis from now on.

when you are using SIP and crossing a firewall you need to configure three things in the sip General settings.

It does not look like you have your nat traversal settings configured properly.

You can find all the information at:
on this page scroll down to sip_nat.conf and sip_general_custom.conf for all the details.

Had the same thing at a client site with a brand new install and all the updates from FreePBX - when you hit a queue you get NOTHING - following the suggestion above I recorded a 1-second wav of silence, and then added it as a Join Announcement and WhaLah - ringback to customers like it’s supposed to.

This site is also using SIP trunks (From Paetec) - I would be happy to help troubleshoot if you need more information.

Let me know if you guys want any other info.



I just wanted to confirm that I’m seeing this bug as well. The workaround does work. Using core version 2.6.0RC2.1 and queues version

I have just upgraded my core to version 2.6.0RC2.1 and queues version and still got problems,however only 2 out of 5 trunks work correctly. Any ideas?