No Ringing for the person who'se calling my DID

Hi Everyone,

I have searched for many hours to find people with similar problems but none of them solved.

I have a Freepbx VOIP system set up for my organization. I have 6 inbound routes for the different locations. They have all been working fine up till now. When i call one of my DID’s from my cell phone, my VOIP phone rings BUT from my cell phone i dont hear any ringing. All i hear is dead air and then the individual answers. One of my DID’s was only doing this about a month ago, this past weekend another one started having the same problem. It randomly did this, we have done no updates on the linux boxes/asterisk.

I have tried re-adding the routes, re-adding the ring groups but no luck! The only thing i could do temporarily is to turn on “on hold music” so that whoever calls atleast hears something and doesn’t hang up.

If i forward the calls to an IVR, it works fine.

I just can’t get the person calling in to hear any ringing… any ideas ladies and gents?

Thanks a million!

So… since no one knows how to fix this, i’ve found a temporary solution.

You can upload a ‘phone ringing sound’ wav file (has to be within the size limit) to the MoH section of FreePbx.

At that point, you can set all your inbound routes/Ring Groups to use this ‘MoH’ ringer as their default sound.

This doesn’t solve the issue by any means, it simply masks the issue until you find out what the underlying issue is.

Sounds like your carrier is not sending ringing. On a inbound call until the call in answered by asterisk it is your carriers job to send the ringing to the person calling.

Which version of freepbx you are using? You can also try using ““r”” option of ““Dial”” application.
here is a piece of description from ““Generate a ringing tone for the calling party, passing no audio from the called channel(s) until one answers. Without this option, Asterisk will generate ring tones automatically where it is appropriate to do so; however, ““r”” will force Asterisk to generate ring tones, even if it is not appropriate. For example, if you used this option to force ringing but the line was busy the user would hear ““RING RIBEEP BEEP BEEP”” (thank you tzanger), which is potentially confusing and/or unprofessional. However, the option is necessary in a couple of places. For example, when you’re dialing multiple channels, call progress information is not consistantly passed back.””

As usual, Tony is correct. Until your system actually answers, generating the ring-tone is the job of the caller’s phone company. It generates the ringing sound when your DID provider sends a signal to it that the phone is ringing. So, if you call your DIDs and hear no ringing, but you can call other people’s DIDs and hear ringing, then your DID provider isn’t sending the signal that the call is ringing.

The method you’ve used will work, but there’s a better way.

First, contact your VOIP Provider and report to them that they are not sending the proper ringing signal.

Second, using the announcements module, create an announcement, but have no announcement actually play. Just don’t select one in the pull-down. Have the announcement module direct the call to the Ring Group/IVR/Whatever that your inboudn route is going to now. Then redirect your inbound route to the announcements module.

This will cause your system to immediately pick-up the call and generate the ring tone.

I’ve combined this method with a modification to the indications.conf file to create my own cool sounding ringback tones…

I have the same problem.

Even with announcement, the calling party cant even hear it …

I am at my wit ends …

I had the same issue with one of my DIDs. I didn’t like the announcement method because that answers the line and billing starts when someone calls you whether you are there or not. To fix this, I removed the DID from INBOUND ROUTES. Then I added this to the extensions_custom.conf:

exten => 9024442222,1,Progress()
same => n,Set(__FROM_DID=${EXTEN})
same => n,Gosub(app-blacklist-check,s,1())
same => n,Set(CDR(did)=${FROM_DID})
same => n,Gosub(cidlookup,cidlookup_3,1())
same => n,Set(CALLERPRES()=allowed_not_screened)
same => n(dest-ext),Goto(ext-group,70,1)

70 is the ring group for this person. 9024442222 is the DID (changed to protect privacy). I copied most of this syntax from the extensions.conf file before I deleted the INBOUND ROUTE. This causes Asterisk to produce the ring tone with answering the line.